0
Started

Unable to switch the language

concat 3 weeks ago • updated by Vlad R 1 day ago 11

---------------------

I have two Filerun sites, but one of them can not switch languages. What is the reason?

- can not switch languages

- can be normal

I confirm the authority of the document is normal, there


Answer

Answer

The control panel option will NOT change YOUR currently set language. Your language was already set when you have accessed FileRun. To change it for yourself, use the option on the login form, not the control panel one. The control panel option changes the DEFAULT language. It applies ONLY to new visitors of the FileRun installation.

Not a bug

We only speak English here, so I translated your post. I have also removed the links, as they weren't relevant.

Please specify the FileRun version and where are you trying to change the languages from (I hope the login form).

elease date: September 25, 2017  FOR PHP7.0

From the front desk and Interface options which can not change the language and make it effective,

Answer

The control panel option will NOT change YOUR currently set language. Your language was already set when you have accessed FileRun. To change it for yourself, use the option on the login form, not the control panel one. The control panel option changes the DEFAULT language. It applies ONLY to new visitors of the FileRun installation.

I try to change the language in the login form, but this setting does not work

After modifying the language, he is still the English interface

Under review

Please try to reupload to your server the folder "system/data/languages" from the FileRun installation zip archive, making sure the FTP program you use uploads in BINARY mode. Do let me know if the problem persists after that.

I try to operate this problem still exists。

But only the Chinese language can not be used, other languages are normal

This seems to be a compatibility issue, I replaced the 360 browser, he can already work properly.

I also cannot change to the following two languages in the login page. It simply roll back to "EN" (English).
- Brazilian Portuguese

- Chinese Traditional

They are the only languages with two words as the language name, so as the language files. I guess it may be the cause of the issue?


My server settings:

- Windows 10

- Abyss Web Server

- PHP 7.0.6


Indeed seems to be a bug in the current FileRun version, causing languages with names containing more than a single word to not work properly. This will be fixed with the upcoming update. In the meantime, a workaround is to rename the language file to remove the space character (for example, rename "system/data/languages/chinese traditional.txt" to "chinesetraditional.txt").