+2
Under review

Web works, Nextcloud Android app shows only an empty @Home folder

Rudhra 1 month ago updated by timfz 5 days ago 12

FileRun installed via docker on Ubuntu 20.04.1, accessed online via traefik.

The web interface works flawlessly, I can see all my files.

Android app Nextcloud installed on Pixel 1, Android 10.

I use the same address as the web: https://files.mydomain.cloud and login.

Now Nextcloud only shows a single folder (that does not actually exist in my folders when I check the web interface):
@Home.


When I click on that foler > Loading ... > No files here

Plus there is a message above it saying "server not available". But the web ui is available, on the same Android device I can login via browser and see all my files.

How can I fix this?

Not sure if it is due to a reboot of my server, but suddenly tonight the @Home folder in Nextcloud shows all my files (even rbind mounts I made, instead of symlinks). Only remaining issue now is: everything is read-only even though the docker container console can delete/edit/create files.

https://feedback.filerun.com/communities/1/topics/1026-docker-version-on-ubuntu-2004-cannot-delete-or-create-new-files-read-only

Hi

Did you mount the Unraid share in your ubuntu docker?

Then you have to set the owner of this files and folders in the docker console to www-data. That's the way I solved this problem. Otherwise you have just the rights of the user which is set in the share on unraid.

Gregor

This was suddenly solved. Not sure how or why. I removed all symlinks and re-did the volume mappings via Docker Compose.

Hi there

Tonight the @Home folder in Nextcloud app on my phone shows only "server not available". On my tablet it shows everything as suposed. Even after new installation the app five times inclusive delete folders related to nextcloud.

Does anyone know what could be the problem?

In another file manager app it works as it should and shows everything...

Gregor

shame sh... after reboot the unraid server. Uptime was 120 days...

I wish to have a native filerun app.

Am I the only one with this problem?

I am having other issues, namely it seems impossible to get OnlyOffice DocumentServer to work with FileRun (see my other topic).

I believe (but can't confirm) you have to make sure www-data user is not just part of the group that owns the ENTIRE folder structure, but ALSO the owner. I tested, even with www-data group having all rights, if user www-data isn't the owner, files will be read-only and I believe NextCloud app>Home folder stays empty.

But it's a crappy sensitve app and I wish FileRun had a better alternative. For now I am just waiting for support to get OnlyOffice Documentserver to work. 

You gave me just a little hope at the end of this tunnel ;-)


The folder where are all the user data from FileRun saved, calls filerun-files and is owned by www-data:

The homefolder from my user "gregi" and is owned by www-data:

I really don't know what else I should change...

Under review

Please do contact us via e-mail (https://filerun.com/contact) with the URL of the FileRun installation and a test user login, so that we can check the Nextcloud empty folder problem for you.

Hi Vlad, thanks for fixing my video problem in the other thread. I had problem stay logged on in the Nextcloud app before. After I disabled download accelerator, I can finally log in. However, the app can not find any file after loading for a couple of minutes. I don't have a @home folder like op does.

My installation is on a Ubuntu 18.04 VM with apache2 and php7.4.

Update: I tried superuser account just now and all files are there. When I switch back to a normal user, loading screen just keeps spinning. My superuser account is using the folder where all other user folders reside.

Hi Vlad

Just for information. I shuted down the version in the ubuntu vm. To many issues...

Since 2 days I have a new version in a unraid docker installed. Everything is running smooth and fast. Even nextcloud mobile app. Nothing in compare with the other one in the ubuntu vm.

Questions... not at the moment.

@timfz: The donwload acceleraton has ended in the same issue than you had. What server are you running?

I run mine on Apache/2.4.29.