0
Not a bug

Weblink URL not complete

dennyhz 4 weeks ago in Feature requests updated by Vlad R 3 weeks ago 5

Photo attached. The WebLink genereated only shows the ending suffix to the weblink where the shared content is accessible. In addition, the "copy" button doesn't copy an actual web address but rather just the weblink suffix. It is not very convenient. Can it be fixed or made to work better. The weblink function itself works just fine....when you piece together your filerun base URL along with the weblink suffix

https://i.imgur.com/d31PJOZ.png

Answer

Answer

Issue Solved. Referenced solution here to find what the syntax is for that advanced customization in the config.php. I think this should be included in the documentation.

https://feedback.filerun.com/communities/1/topics/568-mixed-content-alert-while-access-filerun-behind-nginx-reverse-proxy#comment-1869

Under review

Looks like a problem with your particular FileRun installation. Have you made any customizations to it? (Did you create a config file for it?)

Just a Docker Installation of Filerun from the official dockerhub source. I did not create any custom config. Just added a Magick binary....nothing else.

Mmm.....would it matter if I am Reverse Proxy'ed? I access my filerun instance at https://filerun.domain.com. Locally, my Docker instance is at http://localhost:some_port. I'd like the weblinks to use my Reverse Proxy.

I did not see any special config to declare a FileRun Reverse Proxy Address anywhere in the settings. I see this would be the problem.....FileRun itself has no idea I am actually Reverse Proxy'ing the service.

in "customizables/config.php" this is what I have...there is no reference to this in the advanced configuration documentation. Is there where I would declare my reverse proxy URL.

<?php

$config['url']['root'] = '';

Answer

Issue Solved. Referenced solution here to find what the syntax is for that advanced customization in the config.php. I think this should be included in the documentation.

https://feedback.filerun.com/communities/1/topics/568-mixed-content-alert-while-access-filerun-behind-nginx-reverse-proxy#comment-1869