Not a bug

Ffmpeg has been unable to create thumbnails

huiseqianbi 2 years ago updated 2 years ago 12

Image 663

Image 664

Ffmpeg has been unable to create a thumbnail, all settings seem to be correct, I even tried to re install the system, the thumbnail still can not be created. I installed the version in docker and everything was perfect except that the Office Web viewer couldn't be used.

I even tried to install ffmpeg, but it didn't help.

Under review

Right-click a file, select the "Control panel" option under “More options”. You will find in there troubleshooting tools which will help you find out what happens behind the scene when FileRun tries to generate a thumbnail for the file, and where the problem might be.

What I see is such a hint, but I still don't understand what the mistake is.

I found this in the documentation and it seems that everything is OK.
I am now beginning to wonder if there are any bad system files left because of the problems I caused by resetting the Synology system.
I also found that Synology no longer supports ffmpeg due to copyright issues. I don't know if this is the reason.

The docker installed by me is very stable. Unfortunately, after I use the reverse proxy, the office has made mistakes. Of course, I can use other plug-ins instead, but it's a pity. In the docker version, I don't know how to install libreoffice, so I can't use it at present.

When I use the web to deploy, no reverse proxy, very good, office can work. I can even think about how to install libreoffice in Synology

I prefer to use docker, which is more convenient to install, more stable, simpler, and very user-friendly. Unfortunately, the problem is office and libreoffice.


Discussions online point towards the need of using a newer FFmpeg version on Synology. You would need to find the path of the binary that gets installed via the package manager. "/usr/bin/ffmpeg" is not it. You can confirm this by checking the version (should be higher than 2.7)

About Office Web Viewer, you can try to use a normal port number rather than 3600.

I will try to add a Docker FileRun image that includes LibreOffice.

I've tried to use a lot of random numbers within 10-1024 as ports, and the Office Web viewer still doesn't work. It doesn't matter much anymore. I installed the bulky Onlyoffice instead. Looking forward to adding libreoffice to Docker will be a great experience.

In fact, filerun has attracted a lot of discussions, such as here:https://post.smzdm.com/p/613646/  https://post.smzdm.com/p/ag82pn83/ ,compared with Synology's web, most users still think that the docker version is the best. Thanks again!

Hi, I have installed a new version of ffmpeg, and there will still be a prompt:
I tried indexing again, and it didn't seem to help.

Caching is off. Removing resized image.

That is a successful operation. The thumbnail was made just fine, but removed because that was a test. You should start seeing thumbnails in the user interface.

Thank you very much. I emptied the browser cache, refreshed the page, and it worked.


I changed the port to 8080, successful, office began to work, and perfect.