Permissions issue

llarsen 2 years ago updated 2 years ago 1

I am currently using the community version of Filerun at home, but I have a potential use case for using Filerun at my office so i have been testing a few permissions features. Unfortunately, i seem to be running into an issue and it seems to be a bug...

My goal is to have one "home" directory for a team of users who can manage files that are in the "home" directory. I do not want them to have download or upload access, but i want them to be able to rename, create folders, and move folders to different directories within their home directory.

I set the permissions to "User can make changes to files and folders", but unfortunatly, it wont let me move or create new folders/files, it only allows me to rename stuff. When i try to move a folder, it says i do not have upload permission. So i tried adding upload permissions. I logged out, logged back in, and now when i try, it says i dont have have access to the files! Then i add all permissions and it still says i dont have access to the files...

I tried rebooting the server, which is running Ubuntu 20.04 Server. I also created a new directory on a new drive to be used as their home folder, but still no luck.

Any ideas why this is happening?



I realised, i didnt have permissions to allow downloads of folders, just downloads of files... So i didnt have all permissions allowed.

But im not sure why you would need download or upload permissions to move directories around... No files are being downloaded or uploaded...