Error MKCOL 403 when uploading some files via Nextcloud

Julian H 2 years ago updated by Vlad R 2 years ago 15

Hey, i have filerun setup and running for 2 weeks now. For another account, the nextcloud windows client works perfectly, but now i am trying to use it for my own account and for some files i keep getting "mkcol 403 forbidden" errors, which i can see in the logs of my nginx in front of filerun aswell.

I have no idea, why i have those problems now, and the other account not.

Would be great, if anyone can help me out here.



The fix for this bug is included in the update that is now available for installation via the FileRun control panel. (See https://docs.filerun.com/updating for installing updates.)

Under review

Perhaps there is something in the name of the folder that the sync app is trying to create via the upload. Pressing F12 in the Nextcloud settings page will open the app's log. Perhaps there is some information in there we could use for troubleshooting this for you.

Have tested it with various files and filenames but nothing helps here. Like others pointed out, it seems like its a issue with a 10MB limit with the nextcloud client, atleast it seems like it on my end. Small files are uploaded and synced without a problem, but bigger files never upload or sync at all

I have three files that encounter the same issue. One is 47.6MB, another 17.7 MB, and the third is 9.66 MB, so it may be a bit less than 10MB.


I am facing the same error message when synchronizing with Nextcloud client. Any idea, what is causingthis issue?


I just notice while checking with a smaller set of files that the error seems to be linked to file size. Most (did not check the whole list) file exceed 10MB. I also found a 3-years old thread that 10MB was a limit with nextcloud client. A fix was promissed. Maybe it is a regression?

Same error here. It did not occur prior to the latest FileRun update, but now it does. This is on IIS.

Sorry for the wait, we're working on it.


Please replace the file "system/classes/vendor/FileRun/WebDAV/Server.php" in your FileRun installation with this version "https://bit.ly/3vJ2czF". It should fix the Nextcloud upload problem.

Please note that this patch is compatible only with FileRun version 2021.03.26

This patch will be included in the next update.

Nice, that seems to be working well.

Btw, why is it not possible to upload files and folders starting with a dot? Some internal limitation? I am quite curious as for an example i cant upload git folders, as those have a folder in it called .git

Is this in any way changeable?

Folders starting with a dot are by default hidden in FileRun. You would need to redefine patterns. These are the default values:

$config['app']['hidden_file_names'] = ['.htaccess','.DS_Store', '.SyncID', '.SyncIgnore','*.!sync'];
$config['app']['hidden_folder_names'] = ['.*'];

To allow folders starting with a dot in their names, but still keep FileRun folders hidden (thumbnails, versions, etc), you can set this inside "customizables/config.php" (https://docs.filerun.com/advanced_configuration)

$config['app']['hidden_folder_names'] = ['.filerun.*'];

Thanks for the patch. Any hint how to apply it to Filerun running in docker?

Download the file on your server and the run the below command by replacing the container Id with your own

docker cp Server.php <ContainerID>:/var/www/html/system/classes/vendor/FileRun/WebDAV/Server.php

getting 'copying between containers is not supported"


The fix for this bug is included in the update that is now available for installation via the FileRun control panel. (See https://docs.filerun.com/updating for installing updates.)