Not a bug

Next Cloud Desktop app fails to connect

tong2x 2 years ago updated 2 years ago 8

Filerun is working on my server, is was installed via unzip.php
can upload delete etc.

I am using nextcloud from the download link (Nextcloud-3.2.4-x64)
when connecting it does show the web browser login page and say successfull you may close this

the app will momentarily try to conenct only to fail with the following error

that it failed to connect via secure http with a red marked text

""server replied "403 forbidden" to "PROPFIND htts://files.ognhocgan.net/remote.php/webdav/""

I tried connecting to your test server, it can connect.
I can also see in the user logs that nexcloud has authenticated correctly

is it a file access problem? incorrect path? I recheck the path in permission at "check path" says ok

I also tried cyberduck same problem cant connect

Under review

What HTTP server are you using? (I ask because it is most probably a configuration having it reject WebDAV HTTP methods, such as PROPFIND)

it is a Linux hosting, is there a script/code I can run to check?

I am now also checking with my hosting.

there is no other way to sync files? without webdav and ftp?

much like HTTP upload/sync

You can upload from the web interface via HTTP.

The Sync is using WebDAV, so you need to configure your HTTP server to allow all WebDAV methods. If it's a regular hosting, you should contact the hosting tech support to help you with that.

confirmed it is being blocked by the host.

I guess automatic sync wont be possible

they replied they do not support webdav only on their VPS.

so profind is disable and not supported
no other tool support sync via other method? (except FTP, as ftp has a day limit that needs to be regularly enable also)

That is not a great hosting service. WebDAV is a HTTP-based protocol, so there is no overhead on the server's resources. The hosting service knows it is used for transferring files, so they limit it just to push you towards more expensive options.

Do you mind sharing the name of the hosting service, so that we know to avoid it?


I'll try to ask it in their feedback section if they could enabled it in the future