+1
Answered

favicon missing after update

Paul L 12 months ago updated by Vlad R 9 months ago 4

After updating to the latest version of FileRun, it no longer displays my favicon.ico file.

How do I get this back?

Answer

Answer
Answered

Favicons can be disabled from the FileRun "Interface > Branding" control panel section. Small checkbox called "Browser favicons".

Setting your own icons: replace the files inside "images/favicons/".

Also, the change log says...

  • Deprecated $config['app']['ui']['enable_favicon_ico']. Favicons are enabled now by default and can be disabled from the FileRun control panel.

I must be blind cause I can't seem to find it anywhere in the Control Panel

Answer
Answered

Favicons can be disabled from the FileRun "Interface > Branding" control panel section. Small checkbox called "Browser favicons".

Setting your own icons: replace the files inside "images/favicons/".

Hi Vlad,

Per the above, I understand all that should be needed to add a custom favicon is to replace the files in images/favicons folder. It appears it is not necessary to add a custom config.php file anymore, I believe?


I tried overwriting the 192.png file in the images/favicon folder with the one I'm looking to use. I then cleared my browser cache, closed the browser and tried again. Unfortunately, the new image is not taking. I tried adding a favicon.ico file as well, with no success.

I'm clearly missing something, I'm just not sure what. Is it necessary to update the xml files in this directory as well? I was hoping by simply overwriting the existing image the rest would carry through. Any assistance you can provide would be much appreciated.

There are a few image files in that folder. They are used based on browser requirements, so you would need to replace all of them to make sure.