0
Fixed

Fileshare-Link: Always see "The password needs at least one character." after changing any option

Felix W 1 year ago updated by Vlad R 1 year ago 7

If I try to share a file and to create a download link, I always get a "The password needs at least one character." as soon as I chose any additional option like the "send e-mail notification". The problem is, that I don't want to set a password.

Answer

Answer
Fixed

A FileRun update is now available for installation from the control panel. Among other changes and improvements, it fixes this problem as well.

Under review

On the latest FileRun version, the only way to get this behavior, is if you have manually configured, via the configuration file (https://docs.filerun.com/advanced_configuration), the following:

$config['app']['weblinks']['forcePasswords'] = true;

I just checked the \customizables and did not find a config.php. Is there any other place where this option could be en-/disabled?

No. There was a bug in older FileRun versions related to this, but I have double-checked and none of the newer versions have it. Make sure you are using the latest version.

Your current software version is 2021.12.07

I would download and re-install filerun - maybe not all files were updated (but we didn't have the problem with the version before). Where can I download a ZIP file?

It seems, only non-admin users have this problem. Using the admin, I don't get this error.

EDIT: Only the -ALL- (old/first) admin-user doesn't have this problem. Every new admin-user has the same problem.

I confirm the problem. I will get back with a fix shortly.

Answer
Fixed

A FileRun update is now available for installation from the control panel. Among other changes and improvements, it fixes this problem as well.