0
Under review

question about diacritics and filerun + onlyoffice

ovidiu 11 months ago updated 11 months ago 2

Hi there,

before I pose my question, let me explain the general use case. I'm not even sure the problem lies with filerun it might very well be a onlyoffice issue. Maybe someone can double check with their filerun + onlyoffice instance?

I run filerun on my NAS for my own usage. The file system is ZFS. I simply mount a folder into the filerun docker container inside my docker-compose.yml like this: 

volumes:
- ./data/html:/var/www/html
- ./data/user-files:/user-files
- /sixer/Documents:/user-files/ovi/Documents

so basically, the folder user-files exists but I didn't want to move my documents hence I mount them. 

Now if I right-click inside filerun and create a new file with onlyoffice and use diacritics inside its name for example äöü.docx or äöü.xlsx it opens straight away with onlyoffice, I can edit and save it. I can download it and it all worked but I cannot open it again with onlyoffice. I get the error message below. If I rename the file from within filerun and eliminate diacritics everything works again.

I have found a couple of old (older than 2-3 years) tickets for onlyoffice and nextcloud on github but none had any resolution which would help me figure out where my problems stem from.

Image 937

I would appreciate any feedback.

Under review

I will look into it soon.

thanks for looking into it.


It might be related to the recent (about 8 days ago) upgrade to onlyoffice 7 from formerly v.6? 

The reason I asked here is because I don'T know if onlyoffice saves the files directly or if filerun applies any sanitizing to the file names although that is unlikely as other files i.e. txt files still work even with weird names like "ä ö ü.txt"