0
Answered

Struggles using netxcloud app desktop and android version

josess09 11 months ago updated 10 months ago 6

Image 957

As I mentioned, I have problems trying to use nextcloud app android version with filerun.

I just followed this guide https://docs.filerun.com/mobile_apps and I enabled API. Then, I tried android version and I saw this error: 404 server not found and using nextcloud desktop app: "404 Not found", https://server/nextcloud/status.php

I think it is weird because I wrote my url which i used on the browser.  I want to share that I havent any folder name like nextcloud but i dont know if it is needed. I tried demo version and works fine with nextcloud. When i installed filerun i used this guide http://blog.filerun.com/how-to-install-filerun-on-ubuntu-20/

Under review

Please specify, FileRun version and Nextcloud desktop app version. You should not use "https://server/nextcloud/status.php" as the URL, nor "nextcloud" as we are talking about a FileRun server, right?

I have version 20220113 of Filerun, version 3.4.1 of Nextcloud desktop on Windows 10 and version 3.18.1 of Nextcloud android. Sorry, I have explained myself wrong. I write on nextcloud desktop this: https://server.com and then, a error message appear saying: "404 not found - GET https://server.com/nextcloud/status.php".

We are talking about FileRun but nextcloud app show me this. Regarding nextcloud android, app only show: server not found

Answered

i think you are just not using your FileRun installation URL to connect.

you posted a screenshot from "/remote.php" while you shouldn't have anything to do with that endpoint while using the apps.

I would say that I am using my FileRun installation URL. The same url that I use to connect to FileRun. Could it be a problem because of apache2 conf?. I am using this config on ports.conf:

Listen 80

<IfModule mod_ssl.c>
    # SSL name based virtual hosts are not yet supported, therefore no
    # NameVirtualHost statement here
    Listen 443
</IfModule>   

and 000-default.conf:

<VirtualHost *:80
 ...
</VirtualHost>

sorry, the last comment its mine. I use https://server.ddns.net/ocs/v2.php/cloud/capabilities?format=json and I have a correct answer. I do not know if it could help.

When I used https://mydomain.ddns.net:80 i got a message of failed SSL but when I tried

https://mydomain.ddns.net or https://mydomain.ddns.net:443 I got: server not found. Could be the apache2.conf that i post previously??.