0
Not a bug

cannot create new users among other issues

ruggiero 8 months ago updated by Vlad R 7 months ago 6

What would cause some of the control panel items in Filerun to be inaccessible, aside from those which are meant for enterprise users and obviously not accessible to standard/registered users?  For example, in my installation, clicking ADD on the USERS, ROLES or GROUPS page ends up with the LOADING message flashing for a second and then disappearing, with nothing accomplished.  I had not needed to manage my groups or users til this moment, so I don't know exactly what or when it broke.  Nevertheless, I could use some help.

Note that I cannot EDIT existing users either, same symptom; loading flashes for a second and nothing.  Also, the GUEST USERS page is BLANK.

Not a bug

Doesn't sound like any known possible issues. Any entries in the PHP error log?

[Fri Apr 01 14:02:23.723236 2022] [cgi:error] [pid 128479] [client x.x.x.x:57104] AH01215: thrown in /home/ustorage/system/classes/smarty/libs/sysplugins/smarty_internal_runtime_writefile.php on line 49: /usr/local/cpanel/cgi-sys/ea-php74, referer:mywebsite.comt/?module=cpanel


I changed the ip address and website name, but this is from my logs.

Now that I look at the logs, it seems like a permissions problem on the SYSTEM/DATA/TEMP/SMARTY folder.  It's being created with permissions 771

UPDATE - Seems as though my host changed to a different PHP handler, and FPM was "broken" on the subdomain where I  was hosting Filerun.  What kills me is that these issues seem to crop up at random, and it was only after installing a fresh copy of Filerun on a different subdomain that I was able to figure this out.  The only bug I cannot squash is the eTag error, discussed in that relevant thread.

On a related note, are you testing Filerun under PHP 8.0 or 8.1, or is it already compatible?

This issue can be closed - the issues I experienced were due to a problem with PHP-FPM on the host, which is solved.  Further, I can confirm that the latest Filerun version WORKS under PHP 8.0