0
Not a bug

Javascript not working for $config['app']['weblinks']['allow_html'] = true

EmilyLove 8 months ago updated by Vlad R 7 months ago 1

Trying to view a html file I uploaded with some javascript in it after setting "$config['app']['weblinks']['allow_html'] = true;"

I'm getting an error when I try to do anything that requires javascript: 


Blocked script execution in 'http://100.113.99.5/?module=custom_actions&action=open_in_browser&path=%2FROOT%2FHOME%2FDota%202%20Randomer.htm' because the document's frame is sandboxed and the 'allow-scripts' permission is not set.

How do I fix this?

Not a bug

It won't work andd I will remove the option from documentation. It is very unsafe.

Any user sharing a file with another user would in that case be able to run arbitrary JavaScript code, which can be potentially used for stealing data, access or perform unwanted operations. Unless that's exactly what you are trying to do :)