0
Answered

move/copy submenu removed?

Stefan 6 months ago updated by shuffle 1 month ago 14 1 duplicate

Is the move/copy function in the files/folders submenu removed in the latest version 20220519 ? Thank you. 

Image 1077

Answer

Answer

Also, in your PHP installation, if you get an option of installing the extension "nd_pdo_mysql", try to do so (and after, if still no luck, try to remove the "pdo_mysql").

Duplicates 1

I too am experiencing the missing copy/move submenu.  Ive installed the patch, installed successfully with no errors.  Cleaned my cache, and still no submenu.  Ive tried several different browsers to no avail. 

Any further suggestions?

The copy/move is one of my most highly used features.  Atleast it was.  

I updated to the recent version last week and for the most part really like the new features.  However, we have noticed this same issue with the copy and move context menu items missing.   I have installed the patch and it installed with no errors.  However, this issue still persists.  If anyone has any other tips, I am open to trying them to get this functionality back.

I too reported this issue 3 months ago and have still not been able to work out why the copy/move has disappeared from the menu and drag and drop no longer works, even though it did work in the previous version with no issues, have checked the demo of the latest version and it works so something changed during the update but i don't know a lot about Linux and folder permissions which is the only thing that i can presume is the issue,

I have installed the patch, and not only tried to clear my browser cache, but actually cleared it.  This was first attempted using Google Chrome.  I proceeded to test the functionality using Firefox, Edge, and Internet Explorer all with the same results of no longer having the copy/move menu.  I have had several users test the same all with the same results.

If you can use the contact form on the FileRun website to provide with a test account to your insurance, i will look into this problem for you.

I have added a user and sent the notification to info@filerun.com

Thanks

I also updated the patch and no copy/move context menu appears. Any other suggestions?

Answered

If you applied the patch but the option is still missing, installing PHP's "mysqlnd" extension might help:

sudo apt-get install php-mysqlnd

Answer

Also, in your PHP installation, if you get an option of installing the extension "nd_pdo_mysql", try to do so (and after, if still no luck, try to remove the "pdo_mysql").

Solved: missing move/copy

move/copy missing and can not move files at the web UI after update to 20220519+patch

apache web hosting, version php 7.4 OK

-mysqlnd was already installed and activated, OK

-nd_pdo_mysql was not activated > changing to activated > solved the problem, move/copy is back and I can now move files, OK

-pdf_mysql does not exist on my hosting

Thank you!

Thank you for sharing what worked for you!

Important about MYSQL Extensions.

I have encountered errors on my hosted server with several WordPress sites when testing these extensions to get Filerun move/copy to work. Wordpress couldn't load, database driver error. 

____________________________________________________________________________

I found the following information: https://iqcode.com/code/sql/nd-pdo-mysql-working

MySQL_ND and MySQL PHP extensions are the different sets of drivers. They are
provided by the different teams of developers (MySQL and PHP, respectively).
The most important is the fact that they are mutually exclusive - you can not
select them both simultaneously or mix them in any way. Otherwise, the php code
will throw errors about the connection to the MySQL database.

Since PHP 5.4, mysqlnd is used as the default MySQL driver for all PHP MySQL
extensions. But for PHP 5.3 and older PHP versions libmysqlclient is used as a
connector from PHP to MySQL.

For PHP Selector we need to support both methods, that is why we added nd_*
prefix for PHP MySQL extensions compatible with mysqlnd.

So, as a result:
- libmysqlclient works with mysql, mysqli, pdo_mysql extensions (PHP 4.4 - PHP 5.3);
- mysqlnd works with nd_mysql, nd_mysqli, nd_pdo_mysql extensions (PHP 5.4 - PHP 7.1+).

So you have to choose only one of the following sets:

mysqlnd

nd_mysql

nd_mysqli

nd_pdo_mysql  (you will need this with Filerun 20220519+patch)

# OR #

mysql

mysqli

pdo_mysql

____________________________________________________________________________


I have had the pdo_mysql active as default on my hosted server. I have had to deactivate it first and then activate the necessary nd_pdo_mysql extension. They can not coexist as I understand.