0
Answered

HTTPS in FileRun

Mancusodan 6 months ago updated by Vlad R 6 months ago 2

Hi,

I am trying to enable HTTPS in FileRun but get an error “Failed to test HTTPS connection! The settings have not been saved.” I can connect with HTTP. I am using docker container setup on a UnRaid home server. What do I have to do to setup FileRun to use HTTPS? I would like to access FileRun over the internet with HTTPS with my DDNS address provided by my Asus router, so it is secure. I can get it to work with HTTP over the internet but not HTTPS.

Thanks 

Answered

You don't need to enable anything in FileRun. You just need to start accessing via HTTPS, and if you wish to, add a redirect, from your web server, from HTTP to HTTPS.

If FileRun's own redirect fails, it is because your reverse proxy is not forwarding the information that the used protocol is HTTPS (missing headers such as HTTP_X_FORWARDED_SSL, HTTP_X_FORWARDED_PROTO or HTTP_X_FORWARDED_PORT).

Thanks, I never setup a reverse proxy before and now it is working. 

This is what is did for anyone else having this problem. 

I used Nginx Proxy Manager added my DDNS address on my Asus router to Proxy Hosts like this... (192.168.1.5:9898 is my FileRun server address.)

On my Asus router I did this... (44333) is the HTTPS port Nginx Proxy Manage was set to.