Under review

Moved installation: SSL operation failed

Alain G 10 months ago updated 10 months ago 8

Goof afternoon,

I managed to really mess things op this time. We change our domain name. Moving should have been easy. Found the instructions that I should only have to delete the .dat file and then re-register.

Now unfortunately I get the php error below.

Connection error: Error: Error creating resource: [message] fopen(): SSL operation failed with code 1. OpenSSL Error messages:
error:14090086:SSL routines:ssl3_get_server_certificate:certificate verify failed
[file] /srv/home/maastrichtseverkennersbandnl/domains/mvbmaastricht.nl/htdocs/victor/system/classes/vendor/GuzzleHttp/Handler/StreamHandler.php
[line] 311
[message] fopen(): Failed to enable crypto
[file] /srv/home/maastrichtseverkennersbandnl/domains/mvbmaastricht.nl/htdocs/victor/system/classes/vendor/GuzzleHttp/Handler/StreamHandler.php
[line] 311
[message] fopen(https://www.filerun.com/licensing): failed to open stream: operation failed
[file] /srv/home/maastrichtseverkennersbandnl/domains/mvbmaastricht.nl/htdocs/victor/system/classes/vendor/GuzzleHttp/Handler/StreamHandler.php
[line] 311

I have already tried to set the curl.cainfo(user.ini) to the one in the installation, but I am not able to restart the server as I am on a shared hosting platform.

I also changed all database entries with a replacement query into the new path, same goes for any path present in files.

However I still get this message. This software application is registered to a different server hostname.

Anyone who can help me? Tell me what to do? The installation contains most of our music scores. We are a civilian marchingband non-profit so no budget whatsoever to get any paid support.

Thanks for anyone who is willing to help me.

Though we changed the domain. The server remained the same.

Under review

Hmm, I've been battling this error for an hour today, on an old CentOS 6 server. Updated the CA bundles, with no result. Still don't know what's wrong.

You should contact your hosting service tech support about this.

I have done that already. They don't know it either. Is there any way I can disable SSL within the code and database so I can get it running and then afterwords trying to enable SSL again?

Sorry, comment above was mine, I thought I was logged in.

Would it be possible to do a whole new installation and then import the existing database? Would that get me access to the files? The file location itself is untouched, although I can't get to it over the normal way.

Dear Vlad, would above be possible or would it be possible to do a new installation and then point the storage location to the location where the files are stored in order to get access again? We really need to get to the files...

Update: I have managed to retreive the files. Going for a clean installation now :) Huge releive.