0
Under review

Fatal error after upgrading to the latest version

omar a 5 months ago updated 5 months ago 2

Hello Vlad,

I have been enjoying this software for a while now and decided to upgrade today.

So I use the control panel to upgrade to version 2021.12.07. 

The logs show no error messages and everything seems to be fine as can be seen from the full log here:

https://pastebin.com/2ECQQx9p

The control panel continued to work for the most part (Going to the update tab shows nothing).

And then if I login to my account I get this error


Fatal error: Uncaught TypeError: Return value of FileRun\Files\Utils::PHPiniGetBytes() must be of the type int, float returned in <path>/system/classes/vendor/FileRun/Files/Utils.php:621 Stack trace: #0 <path>/system/classes/vendor/FileRun/Files/Actions/Upload/Utils.php(19): FileRun\Files\Utils::PHPiniGetBytes('upload_max_file...') #1 <path>/system/modules/fileman/sections/default/php/index.php(186): FileRun\Files\Actions\Upload\Utils::getUploadChunkSize() #2 <path>/index.php(181): unknown() #3 {main} thrown in <path>/system/classes/vendor/FileRun/Files/Utils.php on line 621


initial_version.txt shows 2021.06.27 so I assume this is my older version.

I also tried to download a clean installation but I kept my old sessions and database and I still got the same error in the installation wizzard.

My PHP version is 7.3

Under review

What is the value of your configured "upload_max_filesize" and "post_max_size" in your PHP configuration. I have a feeling these are wrong values. They need to be set as a number ending with the letter "M" (or "G").

I had them as
upload_max_filesize = 10G
and
post_max_size = 128M

Changing them back to 20M for both works now.

But I did not have this issue with previous versions. I would like to at least set the upload max filesize to 10G.