0
Under review

Office connection negate contact admin

kingdom computer0 5 months ago updated 5 months ago 6

Hi, i tried open a file .docx from my cloud, i choose open with office, then office ask me username and password. I do it then after 3 try appear a box with "access negate. Contact the administrator" but i dont understand why
Someone can help me? With the demo version of filerun it work

Under review

There isn't enough data to work with. Things that would be useful: the actual error message, better yet a screenshot; HTTP server logs; the browser's dev console HTTP response.

Hi, this is last log from /var/log/httpd/access_log
IP - - [07/Jul/2022:18:22:31 +0200] "GET / HTTP/1.1" 301 - "-" "Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/78.0.3904.108 Safari/537.36"
IP - - [07/Jul/2022:18:22:39 +0200] "\x16\x03\x01" 400 226 "-" "-"
IP - - [07/Jul/2022:18:35:31 +0200] "GET / HTTP/1.1" 301 - "-" "Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/51.0.2704.103 Safari/537.36"
IP - - [07/Jul/2022:18:41:05 +0200] "GET / HTTP/1.1" 301 - "-" "Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/60.0.3112.113 Safari/537.36"
IP - - [07/Jul/2022:18:49:48 +0200] "GET / HTTP/1.1" 301 - "-" "Linux Gnu (cow)"
IP  - - [07/Jul/2022:19:00:23 +0200] "GET /actuator/gateway/routes HTTP/1.1" 404 221 "-" "Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/78.0.3904.108 Safari/537.36"
IP - - [07/Jul/2022:19:07:15 +0200] "POST /GponForm/diag_Form?images/ HTTP/1.1" 404 216 "-" "Hello, World"

And the screen of the error. Can be a problem for the permission about the folder of user? 
Sorry for bad english

EDIT: I see now log report error 404 about Hello, World but the file is not named Hello, World. Did i miss understood?

I see now log report error 404 about Hello, World

That request is unrelated to FileRun, and it is most likely an automatted hack attempt: https://nvd.nist.gov/vuln/detail/cve-2018-10561

You should hide better your web server. (Maybe use a custom port number.)

This is from /var/log/httpd/site_access_log


IP- - [08/Jul/2022:20:42:22 +0200] "POST /?module=fileman§ion=get&page=details HTTP/1.1" 200 155
IP- - [08/Jul/2022:20:42:22 +0200] "GET /a/?gid=4 HTTP/1.1" 304 -
IP- - [08/Jul/2022:20:42:22 +0200] "POST /?module=fileman§ion=do&page=download&archiveName=Direttivo HTTP/1.1" 200 118
IP- - [08/Jul/2022:20:42:23 +0200] "GET /sw.js?v=20220519 HTTP/1.1" 304 -
IP- - [08/Jul/2022:20:43:31 +0200] "POST /?module=custom_actions&action=msoffice&method=run HTTP/1.1" 303 -
IP- - [08/Jul/2022:20:43:32 +0200] "OPTIONS /dav.php/@Home/ HTTP/1.1" 401 46
IP- - [08/Jul/2022:20:43:32 +0200] "OPTIONS /dav.php/@Home/ HTTP/1.1" 401 46
IP- - [08/Jul/2022:20:43:33 +0200] "GET /sw.js?v=20220519 HTTP/1.1" 304 -
IP- - [08/Jul/2022:20:43:33 +0200] "OPTIONS /dav.php/@Home/ HTTP/1.1" 401 46
IP- - [08/Jul/2022:20:43:34 +0200] "OPTIONS /dav.php/@Home/ HTTP/1.1" 401 46
IP- - [08/Jul/2022:20:43:35 +0200] "OPTIONS /dav.php/@Home/ HTTP/1.1" 401 46
IP- - [08/Jul/2022:20:43:35 +0200] "OPTIONS /dav.php/@Home/ HTTP/1.1" 401 46
IP- - [08/Jul/2022:20:43:35 +0200] "OPTIONS /dav.php/@Home/ HTTP/1.1" 401 46
IP- - [08/Jul/2022:20:43:35 +0200] "OPTIONS /dav.php/@Home/ HTTP/1.1" 401 46
IP- - [08/Jul/2022:20:43:35 +0200] "OPTIONS /dav.php/@Home/ HTTP/1.1" 401 46
IP- - [08/Jul/2022:20:43:35 +0200] "OPTIONS /dav.php/@Home/ HTTP/1.1" 401 46
IP- - [08/Jul/2022:20:43:35 +0200] "OPTIONS /dav.php/@Home/ HTTP/1.1" 401 46
IP- - [08/Jul/2022:20:43:35 +0200] "OPTIONS /dav.php/@Home/ HTTP/1.1" 401 46
IP- - [08/Jul/2022:20:43:35 +0200] "OPTIONS /dav.php/@Home/ HTTP/1.1" 401 46
IP- - [08/Jul/2022:20:43:35 +0200] "HEAD /dav.php/@Home/ciao.docx HTTP/1.1" 401 -
IP- - [08/Jul/2022:20:43:35 +0200] "HEAD /dav.php/@Home/ciao.docx HTTP/1.1" 401 -
IP- - [08/Jul/2022:20:43:35 +0200] "HEAD /dav.php/@Home/ciao.docx HTTP/1.1" 401 -
IP- - [08/Jul/2022:20:43:36 +0200] "HEAD /dav.php/@Home/ciao.docx HTTP/1.1" 401 -
IP- - [08/Jul/2022:20:43:36 +0200] "HEAD /dav.php/@Home/ciao.docx HTTP/1.1" 401 -


ciao.docx is the file im tring to edit on office. I tried to change permission to file but nothing happend, i try with 777 and 

chown -R apache:apache /var/www/html/system/data/<folder of user> 

but nothing change

Most probably your HTTP server is not forwarding the authentication to PHP. In other words, the username and password that you are typing the authentication prompt, do not reach FileRun.

What HTTP server are you using, and what OS?

I'm using httpd on centos 7
httpd -v
Server version: Apache/2.4.6 (CentOS)
Server built: Mar 24 2022 14:57:57