+1
Under review

Shared link to folders shows no thumbnails when default thumbnail location moved

dave 5 months ago updated by langerdennis 1 month ago 6

Everything works perfectly in my docker installation of current afian container of Filerun and mysql 5.7, IF I leave the default thumbnail location. If I relocate thumbnails to their own folder as allowable in "customizable," everything works fine EXCEPT when sharing a folder with web link - the thumbnails are always missing in the link page. The thumbnails and folder in which they are saved have chmod 777 forced for testing. What am I missing or is there a little bug here somewhere? Thanks again for a great solution for our family photo archiving efforts,,,,

Struggling with the exact same issue. When I created an album with the thumbnails located next to the file location, the album functionality would work flawlessly - the thumbnails would show, previews were loading and the download worked fine as well. With the advanced option for cache location mentioned above, the browser would throw me 404 errors when trying to display thumbnails or previews in the web album - it is working fine everywhere else in the user panel, just not in the public album:

files.oberfeld.me/:1          Failed to load resource: the server responded with a status of 404 ()

As soon as I go back into config.php, comment out the cache location and refresh the album website, all thumbnails are generating on demand next to the file location again (which is expected behavior) and are displayed correctly in the web album. When I then edit config.php again to let it point to the desired central thumbnail location and clear the browser cache, the thumbnails are again not loading, throwing error messages in Chrome's developer console. The download functionality is working fine either way. User permissions are exactly the same in both thumbnail locations (next to the file and at the defined location):

drwxr-xr-x 1 www-data www-data

Since the error message is a 404, I assume the web album functionality might not correctly be looking for thumbnails at the new location after it has been manually specified. Example album

PS: I have ruled out my reverse proxy as the problem - the problem also applied when accessing via local IP (before I had the installation registered and therefore lost access via local IP). For now I have created a separate docker-compose stack only mounting the folder I want to expose as a web album as a workaround, with thumbnails existing next to the files...

Other than that everything works flawlessly and I cannot thank you enough for this great piece of software!

Somehow I cannot edit my comment anymore - I have removed the example album, since I did not want to run a separate stack. The issue should be easy to replicate, though. I am now back to storing my thumbnails next to the file location until the central thumbnail cache is working with external albums.

same issue here.

some thumbnails cannot display (404 Not found) after setting up $config['path']['thumbnail_cache']
(I am using reverse proxy too)

+1
Under review

the default FileRun install with docker comes with Apache mod_xsendfile enabled from the FileRun control panel as download accelerator. This plugin is configured in the Apache configuration with a root folder where it can operate.

disability the use of the accelerator for now would be a temporary solution, unless your thumbnail cache path starts the same as the path where the user files are located.

It worked! I have set LiteSpeed as download accelerator, and no more 404 on the thumbnail.

Thank you!

Worked for me as well, thanks!

Slightly off-topic: Unfortunately, I had to migrate to an nginx-based VM since my Docker install now crashes my server with massive iowait whenever I access via reverse-proxy (and only via reverse-proxy, accessing through local IP is no problem). Unfortunately I could not narrow down the problem, only that it is the FileRun-web container which cannot be stopped anymore and renders everything unresponsive. The log-files show multiple internal Apache dummy connections. Since I do not know where exactly the problem is (probably not within FileRun itself), I won't open a support thread here but live with my VM-workaround for now. Just in case anyone has faced a similar problem and has an idea I am leaving this comment though ;-) PS: Running on Unraid via docker-compose