0
Under review

Web links versions

filerun 5 months ago updated by Vlad R 5 months ago 3

Hi

Running latest version of Filerun (20220519) on docker.

When sharing a file/document via web share functionality - the web share link seems to be locked to specific version of file.

So, when I create a new .doc or .xlsx file and create a web share (preview) - I'm always shown that version even if the underlying file is updated.

If I go in and do preview via filerun web interface, the correct version is shown.

(as an FYI, my default preview is office web viewer)

Under review

You are certainly looking at a cached version of the file. FileRun always serves the active file.

OK (and this is not a high priority) - but I have now done a fair bit of testing and I'm pretty sure it's not down to caching (but totally accept that I may be wrong).

Test done:

1. Create new docx file with 1 line (Test).

2. Create share link (default preview + download)

3. Edit docx file with additional line (Test 2)

4. Access shared link on "clean" separate browser and also separate device

5. Previewed document shows version 1 of document

6. If I download the document it is the correct version with both lines of text

Notes:

1. I have tried preview with both internally setup Onlyoffice and Office Web viewer (same result on both)

2. I have checked that (nginx) proxy is not set to cache - but again, the downloaded version of file is correct

3. Internally in filerun webinterface the weblink looks ok (showing the right version) - but the url is of course different internally than the web share link

Skip the preview, use the shared link to download the file, and actually check the file not what some third-party online services might show you.