Under review

Nextcloud app on Android and iOS = error invalid_client client authentication failed.

bjfphoto 6 months ago updated by Vlad R 4 months ago 6

Looked at older topics and none seem recent or to cover my exact issue.

Most recent version of filerun 2022051

Most recent version of both Android and iOS Nextcloud apps.

It was working properly for awhile but today I was logged out and attempted to add the server to the apps again and am greeted with  
{"error":"invalid_client","message":"Client authentication failed."}

Filerun in running in a Docker on unRaid and access using a cloudflare tunnel. I was able to access and connect with the apps previously. I have restarted my docker containers and uninstalled and reinstalled the apps on the devices. I am able to access the demo.filerun.com and my nextcloud instance with the apps. Im not sure what changed to stop access with the Nextcloud app as I didn't modify anything.

I've also tried after enabling  "allow unsafe access over plain HTTP" and that didn't work either.

On another note...
In looking for a solution I also attempted access via webDAV with FE file explored on iOS, WinSCP on windows and Cx file explorer on Android and none could connect. (I'm sure that has to do with the Cloudflare configuration)

Android: CX File Explorer and FolderSync both connect just fine here via webDAV.

laptop running Manjaro: OwnCloud Desktop Cliënt runs fine.

FileRun Running via Docker Compose.  Domain provider is PorkBun, highly recommended  because it uses standards for TLS challenge etc.

I use Caddy as proxy and didnt have to tinker around. In my PorkBun domain account I created the CNAME subdomain for my FileRun instance, then ran docker compose. That's it.

Cloudflare offers you lots of stuff and features, most of you don't need in most usecases. Only complicates stuff.

I had the same error while testing filerun as a replacement of nextcloud. Turns out it is the URL I used.

Instead of https://myfilerun.com/dav.php or the barcode when connecting a new app.

Use https://myfilerun.com and this will load the webpage for authentication and work.

However on iOS the nextcloud app is very slow to load pictures compared to ES File Explorer.

Tried this at the time and didn't work.
Tried again, still doesn't

Must be something to do with cloudflare then which I have no idea about. I guess it is like a VPN. I just access mine via a nginx reverse proxy over the internet so the configs wouldn't be any use to you. 

Really wish this would get some attention.
Apps and WebDAV still don't work.

Under review

Please contact us with the URL of your FileRun installation and a test login account: https://filerun.com/contact I will look into it for you. Considering you are the only person reporting this problem, is not a common setup. Have you tried without Cloudflare? Also, without any reverse proxies if you are using any?