0
Answered

segmentation fault with php > 7.2 with metadata_update_file_type.php

johnny u 4 months ago updated 3 months ago 7

hello,

i'm using filerun on a arm-v7 (synology ds214+) and use metadata_update_file_type.php to update files that are placed from outside of filerun.

if i try the cron-script with a php-version greater than 7.2 (7.3, 7.4) it terminates with "Segmentation fault (core dumped)"

i'm configure the ioncube-loader with a ini-file and the parameter "-c"

The Problem: after upgrading the synology to dsm7 there is no php 7.2

is there a way to use metadata_update_file_type.php with php 7.4?

thanks,

sincerely, johnny u

Answered

Segmentation faults are not FileRun errors, but lower-level programs errors, such as PHP crashing.

I recommend you to reinstall the ionCube extension, using the latest version. If the problem persists, upgrade PHP to a newer version. While doing that, you need to take into account FileRun's compatibility. Please see: https://docs.filerun.com/php7

i've tried ioncube-archive-Versions 11.0.0 and the latest (12.0.2), i'm using php 7.4 with ioncube 11.0.0 to run filerun, which works fine.

The Problem exists only if i try to call the cron-script on cli with php 7.4.28 (ioncube_loader_lin_7.4.so from 12.0.2 and 11.0.0) or php 7.3.33 (ioncube_loader_lin_7.3.so from 12.0.2). I have also tried php 8.0.17, but there is no support from ioncube-loader.

Before i have upgraded to dsm7 i ran the script with php 7.2 and ioncube 11.0.0 without problems.

How about the metadata extraction troubleshooting tool from the file's control panel (via FileRun's UI). Does that work?

yes, works, exiftool-tags are printed

hi Vlad,

is there any progress on this topic?

Or will it be possible again with the a new version, which also supports php8, to update metadata via cli, or is there any other workaround?

thanks in advance

If you have a regular PHP error, then I can help troubleshoot. As mentioned originally, segmentation faults are not FileRun problems, but your PHP installation, or its configuration, or the way it is being executed is faulty. There is nothing we can do about it on the FileRun side.

it's really hard for me to find the problem, because the cron-php-script is protected with ioncube so i cannot look into the source and the phpdebug has the same segmantation-fault when i use it with a ini-file with enabled ioncube-loader.

is there a way to get the source of metadata_update_file_type.php?

another question: in what combination (php-version and ioncube-loader-version) did you get this script run?