0
Under review

Filerun in docker: WebDAV access failed with 405 error

oleggus 2 weeks ago updated by Rudhra 2 weeks ago 5

I have Filerun running in Docker on Ubuntu. It works fine I am able to use Nextcloud Android app to sync files.

Recently I installed Floccus app that suppose to sync your bookmarks via WebDAV and my connection failed with 405 error.

I came across this topic - https://feedback.filerun.com/communities/1/topics/1244-cantt-connect-via-webdav which looks similar to my case except I run Filerun in Docker behind Traefik and have no idea in what webserver should I allow non-standard verbs?

Traefik logs look good, it just pass through whatever is sent, Filerun logs show this:

192.168.0.10 - - [15/Jan/2023:17:13:11 +0000] "PUT /bookmarks.xbel.lock HTTP/1.1" 405 502 "-" "Dalvik/2.1.0 (Linux; U; Android 13; SM-G996U Build/TP1A.220624.014)"

Under review

only upload/put errors like that, otherwise WebDAV access works fine? If so, it's your reverse proxy and not FileRun.

you can verify which server throws the error by checking the http access and error logs.

I use Docker with Caddy-Docker-Proxy instead of Traefik. I installed Floccus and noticed this app is really not useable yet. It crashed constantly during setup wizard and when switching between windows (to connect app in FileRun and copy/paste the URL and credentials) the wizard constantly restarted, clearing my previously pasted credentials.

Even after adding all credentials I experienced crashes constantly. I am on Android 13.

After getting through the wizard to add webDAV successfully I also got the same error you did, but the constant crashes could well be related.

Clearly the app is in early development and not stable enough. I am convinced it is not my setup (or FileRun) because I use FileRun WebDAV just fine with other apps like CX File Explorer and FolderSync.

Ruhdra, I spinned up another docker (https://hub.docker.com/r/ugeek/webdav) and Floccus has no issues to connect. I synched 2 PCs and S21 phone without a problem so far.

Vlad, I tried to connect to Filerun WebDAV from Windows Explorer and WinScp like explained here - https://docs.filerun.com/webdav and I see same 405 error in Filerun docker logs in both cases( collected from Portainer).

Nextcloud app connects fine.

:

192.168.0.10 - - [16/Jan/2023:00:29:45 +0000] "OPTIONS /filerun/dav.php HTTP/1.1" 200 137 "-" "Microsoft-WebDAV-MiniRedir/10.0.22621"

192.168.0.10 - - [16/Jan/2023:00:29:45 +0000] "PROPFIND /filerun/dav.php HTTP/1.1" 405 507 "-" "Microsoft-WebDAV-MiniRedir/10.0.22621"

192.168.0.10 - - [16/Jan/2023:00:29:45 +0000] "PROPFIND /filerun HTTP/1.1" 405 507 "-" "Microsoft-WebDAV-MiniRedir/10.0.22621"

192.168.0.10 - - [16/Jan/2023:00:29:46 +0000] "PROPFIND /filerun/dav.php HTTP/1.1" 405 507 "-" "Microsoft-WebDAV-MiniRedir/10.0.22621"

192.168.0.10 - - [16/Jan/2023:00:29:46 +0000] "PROPFIND /filerun HTTP/1.1" 405 507 "-" "Microsoft-WebDAV-MiniRedir/10.0.22621"

192.168.0.10 - - [16/Jan/2023:00:29:46 +0000] "PROPFIND /filerun HTTP/1.1" 405 507 "-" "Microsoft-WebDAV-MiniRedir/10.0.22621"

192.168.0.10 - - [16/Jan/2023:00:29:46 +0000] "PROPFIND /filerun/dav.php HTTP/1.1" 405 507 "-" "Microsoft-WebDAV-MiniRedir/10.0.22621"

192.168.0.10 - - [16/Jan/2023:00:29:46 +0000] "PROPFIND /filerun HTTP/1.1" 405 507 "-" "Microsoft-WebDAV-MiniRedir/10.0.22621"

192.168.0.10 - - [16/Jan/2023:00:26:15 +0000] "OPTIONS /Media HTTP/1.1" 200 137 "-" "WinSCP/5.21.6 neon/0.32.4"

192.168.0.10 - - [16/Jan/2023:00:26:15 +0000] "PROPFIND /Media/ HTTP/1.1" 405 507 "-" "WinSCP/5.21.6 neon/0.32.4"

192.168.0.10 - - [16/Jan/2023:00:26:16 +0000] "PROPFIND /Media/ HTTP/1.1" 405 507 "-" "WinSCP/5.21.6 neon/0.32.4"

Are you testing all of those cases through HTTPS?

But the app is unusable. It's very unstable, can't really use it yet. So there is no rush to make it work. Hope this doesn't get priority. I find it very hard to test what works and what doesn't while the app keeps crashing.