0
Answered

Ioncube Loader error when updating (in CENTOS 6.9 + cPanel)).

mrlawrencelam 2 years ago updated by Vlad R 2 years ago 3

I current software version is 2017.01.23 and I am trying to install "Update 2017.03.18".

My server is running CENTOS 6.9 + cPanel. The Ioncube Loader is version 5.1.1 which is the latest version available included in cPanel's WHM >> EasyApache 3.


I am getting this error:


Fatal error:  The file /home/xxxxx/public_html/upload/system/data/temp/_unzipped_update/update.php cannot be decoded
by this version of the ionCube Loader.
 If you are the administrator of this site
then please install the latest version of the ionCube Loader.
 in Unknown on line 0


Ioncube Loader version 5.1.1 is not enough? 

Answer

Answer
Answered

You would need to update ionCube Loader to a newer version. At least version 6, but version 10 is recommended.

Answer
Answered

You would need to update ionCube Loader to a newer version. At least version 6, but version 10 is recommended.

Unfortunately i don't have an update in my cpanel for ioncube 10.


i am using php5.6 apache3 


Please help me with this

cPanel doesn't usually offer options to update PHP extensions, and this is usually done manually, by replacing the extension file on the server.

If you are using a hosting service, then their tech support should be able to help you update ionCube to version 6 (or newer). Otherwise, the server administrator should handle this for you.