0
Answered

There was an invalid response to an authenticated webdav request

puurlek 3 years ago updated by nicapascual29 1 day ago 6
When trying to connect to my FileRun installation, running on HTTPS, with Nextcloud or ownCloud, I get the error stated in the title, after entering the correct login information. I have not made additional configurations to Nginx for Webdav compatibility. Is this necessary? A nudge in the right direction would be very appreciated.


Answer

Answer
Answered

A solution was found in the following NGINX guide: "https://www.nginx.com/resources/wiki/start/topics/examples/phpfcgi/".
The correct handling of PATH_INFO enabled FileRun's URL "http://hostname/dav.php/" (note trailing slash) to work properly and allow WebDAV access.

Under review

I don't think we've ever tested FileRun's WebDAV access when running directly on NGINX. There isn't much troubleshooting information either, but if you contact us via e-mail and provide us temporary access to your FileRun installation, we can check the HTTP communication between a Nextcloud client and your server, to see what goes wrong.

Answer
Answered

A solution was found in the following NGINX guide: "https://www.nginx.com/resources/wiki/start/topics/examples/phpfcgi/".
The correct handling of PATH_INFO enabled FileRun's URL "http://hostname/dav.php/" (note trailing slash) to work properly and allow WebDAV access.


Hello. I'm having the same problem. 
Here's my dav.php

I'm only using shared hosting on Namecheap but doesn't know much regarding this stuff.
Hoping for your swift response :)

When connecting to FileRun via Nextcloud, just set the URL of your FileRun installation to connect to. Do not apend "/dav.php/" to the URL.

Hello,

I appreaciate your immediate response.

It was all working fine earlier. Also, I didn't put "/dav.php/" to my URL when connecting it to my nextcloud.

See attached file below. 

Happens to me. I didn't do anything. :|