0
Answered

Thumnails problems

werner 4 months ago • updated by Vlad R 3 months ago 10


hi

just installed filerun. great tool! i will use it only for viewing pdf files.


So my first question:

Is php 7 a must? Or is it only a  recommendation for security and performance reasons?

qnap itself supports only php 5.6, ioncube is working!

Imagemagick AND gs are installed and working correctly.


The only thing a can´t get the thumbs to get displayed correctly. When i import pdf files filerun is only creating 400_400_cover[1].png.lock files.

until that point the files showing the red "pdf" icon as thumbs


When i run make_thumbs.php manually the script is generating png thumbs addionally to the lockfiles.


in filerun there are still red red icons displayed. when i delete the .lock files the blue placeholder thumbs in filerun gettings displayed.


The thumbs files are correctly created and viewable. Download and preview of the pdfs are working!


Maybe anybody can give me a hint what im doing wrong.


thx

Werner


now i tested other filetypes! pictures are working, so i tried to find the differences!


jpgs ==> 400_400_cover[1].png are generated

pdfs ==> 400_400_contain[1].png are generated


when i rename the contain to cover the thumbs are working!!!!!!

Under review

PHP 7 is not a requirement at this time.

What ImageMagick version are you using?

[~] # convert -version
Version: ImageMagick 6.9.4-8 Q16 x86_64 2017-12-30 http://www.imagemagick.org
Copyright: Copyright (C) 1999-2016 ImageMagick Studio LLC
License: http://www.imagemagick.org/script/license.php
Features: Cipher DPC
Delegates (built-in): bzlib jng jpeg png tiff

and

[~] # gs
GPL Ghostscript 9.16 (2015-03-30)
Copyright (C) 2015 Artifex Software, Inc.  All rights reserved.
This software comes with NO WARRANTY: see the file PUBLIC for details.


Was it working ok for non-PDF files? Does the web access generates thumbs for the regular image files (jpg)?

PHP-FPM might need a small adjustement. Try adding the following inside your server "php-fpm.conf" file:


env[PATH] = /usr/local/bin:/usr/bin:/bin

hi vlad,

thanks for the info, i think you found the problem, my php-fpm is not starting because of a missing conf file. i will try to fix it and give you a feedback

hi,

now i´ve got a complete apache package with the newest php packages for the qnap BUT with php 7.2 i´m receiving the follwing errors:


PHP Fatal error:  The file .../filerun/index.php was encoded by the ionCube Encoder for PHP 5.6 and cannot run under PHP 7.1 or later.\n Please ask the provider of the script to provide a version encoded with the ionCube Encoder for PHP 7.1. in Unknown on line 0


Is it possible that you also provide a version which is compile for php 7.2 too


tthx

Werner



PHP 7.2 is not yet supported. Soon though.

FileRun for PHP 7.2 can be now downloaded from our website.