0
Answered

Tags in details section

Murat A 2 years ago updated 2 years ago 5

Hello,

I've installed and updated FileRun on QNAP sistem (TS-EC1280U v.4.3.4), and everything works fine. However, when I click on a photo, tags does not show on Details section. To test this, I've installed it on windows and linux on my PC, and there is no problem. I uploaded the same photo to both these systems, and tags show up without any problem. Solving this issue is critical for me as we (Ministry of Culture and Tourism, General Directorate of Promotion) will be purchasing FileRun Enterprise License (i.e. unlimited user license) soon.

Any help would be appreciated.

Best regards.

Answer

Answer

All PHP extensions required for FileRun are enabled in QNAP. I think the problem was because files and folders were loaded to QNAP before FileRun was setup. Anyway, I've solved the problem by manually indexing folders. First, I've tried following code, but didn't work. Later, I've started indexing folders with right click, and it worked. Thanks.

/usr/local/apache/bin/php metadata_update_file_type.php /share
Under review

Hi! For FileRun to be able to extract tags and details from image files, PHP needs to have the EXIF extension installed/enabled. It is probably missing on the QNAP setup. Contact us via e-mail and we'll try to help you with it.


Answer

All PHP extensions required for FileRun are enabled in QNAP. I think the problem was because files and folders were loaded to QNAP before FileRun was setup. Anyway, I've solved the problem by manually indexing folders. First, I've tried following code, but didn't work. Later, I've started indexing folders with right click, and it worked. Thanks.

/usr/local/apache/bin/php metadata_update_file_type.php /share

Ah, yes, existing files do not get processed automatically. You can also do it from the web interface, being logged in as superuser, right-click a folder, go to "More options", and select "Index files". This is not needed for files that are uploaded thorough FileRun.

That's exactly how I did it.