0
Answered

Some EPS and AI vectors does not show the thumbnail and preview

ezequiel 2 years ago updated by Vlad R 2 years ago 3

In some EPS and AI illustrator files do not show the thumbnail or preview. It shows an icon with a red slash in the middle. ImageMagick generates the preview of the files Eps and AI, In some cases yes and others no. Anyone has a solution for this?

I am using ImageMagick-7.0.7-25-Q16-x64-static



Answer

Answer
Answered

Thanks for the samples. Using Ghostscript 9.15 I am getting very mixed results: thumbnail for "not thumbnail.ai" but none for the other two files.


Ghostscript is used by ImageMagick automatically, when available. It is required for any PostScript file types (such as PDF and EPS/AI files)


Updating Ghostscript to version 9.22 (latest one available at the time of this writing) seems to fix the problem and I can have thumbnails for all three sample files.

Under review

If you post a link to a sample file for which thumbnail generation always fails, we can check it for you.

If it doesn't always fail for the same file, you should check your server's software as the problem is not from FileRun. Perhaps trying different ImageMagick and Ghostscript versions.

Thank you for your response. The problem of the non-generating of the thumbnail does it all the time with the same files. It never generates for those files and the files are in perfect condition, thy are not corrupt. I will send you a link with 3 files which one works with the thumbnail and the 2 other dont. 

You mentioned GhostScript that comes integrated with ImageMagick or is it a separate instance. Because in the Filerun, I dont see an option to put a path to the Ghostscript.


https://wetransfer.com/downloads/3f8fe0a11cfb32db230dd869cfd02ffd20180305113547/d332cd


Answer
Answered

Thanks for the samples. Using Ghostscript 9.15 I am getting very mixed results: thumbnail for "not thumbnail.ai" but none for the other two files.


Ghostscript is used by ImageMagick automatically, when available. It is required for any PostScript file types (such as PDF and EPS/AI files)


Updating Ghostscript to version 9.22 (latest one available at the time of this writing) seems to fix the problem and I can have thumbnails for all three sample files.