0
Closed for lack of information

Shared links have no domain

Nick 3 years ago updated by Vlad R 3 years ago 7

Hi All,


I've just installed filerun using docker behind the jwilder/nginx-proxy proxy.  I ran the installation using the full URL of the server, but every time I create a share link the link does not include the domain name.  All I get is something along the lines of:


wl/?id=u3OImcjOsmZb76BKv89FcnRmblZprMdq


Is there somewhere that I have to set the domain name?


Thanks.

Under review

You must have a configuration problem in your reverse-proxy. Most probably not forwarding the "Host" header properly.

Have you set the VIRTUAL_HOST environment variable for the "jwilder/nginx-proxy" Docker container?

Yes, I have that set.  I am accessing filerun via the proxy at the proxied address, so that has to be correct.  I haven't had a chance to look into the host header thing yet, but I will so as soon as I can.  That said, I am running a number or other sites behind the proxy and none of them seem to be having a problem.

The Host HTTP header doesn't have to be included for a web server to be accessible, which doesn't make it right either. Running other sites is also not an indication that the configuration is correct or standard.

Make a PHP file containing 

<?php phpinfo();

access it with a browser and look for HTTP_HOST. It's most certainly missing although it shouldn't.

Hi Vlad,


I did the above and the HTTP_HOST value is present and set to the correct value.


I also tried to map a port on the docker host to bypass the proxy and got "This software application is registered to a different server hostname." so it seems to know about the change at least...


Thanks


Nick

If you contact us privately and provide the URL of your FileRun installation and a test login, we can troubleshoot the problem for you.

Closed for lack of information