0
Answered

WebDAV access, under Windows 2016

pw 1 year ago • updated 4 days ago 11

Just tried to get Filerun to work on an Windows 2016 server under IIS.
PHP 7.1, ioncube loader 7.1

Can access and configure Filerun via Web Interface.

But when using the NextCloud Client on Windows PC I'm getting "server replied: Method not allowed"

If I try to access the URL https://mysever/FileRun/remote.php/webdav (which is exactly the URL that's been accessed by the NextCloud Client) with a web browser, I'm getting: "This XML file does not appear to have any style information associated with it. " followed by some XML output.

Unfortunately there is almost no documentation on the windows implementation and the very few articles I could find are conflicting on top. As is with the whole php config info which partially contradicts what is written in the php.ini comments of version 7.1...

Can you give me a hint how to get this to work?

Best
Peter

Under review
server replied: Method not allowed

You need to fix your IIS configuration, find PHP under "Handler Mappings", double-click the entry, click "Request Restrictions...", switch to the "Verbs" tab and select "All verbs". Save the changes and restart IIS.

Sorry, checked that.

It's set correctly to "all Verbs".

Restarted Server anyway. Didn't change anything...


Look for other handlers that you might have and remove them if not needed, or disable them. The usual suspects are "WebDAV" and "OPTIONSVerbHandler".

Removed WebDav (wich was disabled anyway) and OPTIONSVerbHandler. Leaving PHP via FastCGI, PHP53 via FastCGI, TRACEVerbHandler and StaticFile. Still no change. Method Not Allowed

I suggest getting assistance from an experienced IIS server administrator, to check the server logs and identify the reason why your web server still rejects the WebDAV related HTTP requests.

With a default IIS configuration and a default PHP installation (installed using Web Platform Installer), allowing all the verbs on the PHP handler is generally all that it takes.

Hi, i had installed filerun in the windows environment also. i installed filerun using xampp in localhost. i get different issue. on weblink share, when i open the shared link it show blank page. i try to find the solution and an answer is remove the .htaccess file. i remove it but still blank page i got when shared link via weblink i open. any advice for this problem? thanks.

You are welcome to signup and start a new topic.

Sounds like this is not a great product for a windows server environment.  No documentation on how to install on Windows. :-(

FileRun runs great on Windows, however, being a web-based application it does require one to have web-sever administration knowledge. While it might lack documentation, and you're free to criticize that, your first statement is quite a generalization (borderlining trolling).

To get you started:


  1. Install IIS and PHP (7.2 is highly recommended):
    1. https://docs.microsoft.com/en-us/iis/get-started/whats-new-in-iis-8/installing-iis-8-on-windows-server-2012
    2. https://docs.microsoft.com/en-us/iis/application-frameworks/scenario-build-a-php-website-on-iis/configuring-step-1-install-iis-and-php
  2. Install MySQL: https://dev.mysql.com/downloads/mysql/
  3. Optimize the PHP configuration: http://docs.filerun.com/php_configuration
  4. Install ionCube PHP extension: http://docs.filerun.com/ioncube#manual_ioncube_installation
  5. Install FileRun: http://docs.filerun.com/filerun_install_guide#upload_filerun_to_your_server

If you haven't installed PHP and a PHP-based application before, I strongly recommend getting help from somebody that did.

Good luck!

I am running into the same issue.  I've gone through the steps above and still nothing.  I can browse to /dav.php on my browser (looks just like normal index.php), I browse to /remote.php/webdav/ and I get an xml page.  If I try to connect on my phone via a webdav app I get an error 405.

Also, I tried to create a user on this page via the Sign In/Sign Up, and there is no Sign Up option.