Under review

Windows 2016 Installation

pw 9 months ago • updated 8 months ago 8

Just tried to get Filerun to work on an Windows 2016 server under IIS.
PHP 7.1, ioncube loader 7.1

Can access and configure Filerun via Web Interface.

But when using the NextCloud Client on Windows PC I'm getting "server replied: Method not allowed"

If I try to access the URL
https://mysever/FileRun/remote.php/webdav (which is exactly the URL that's been accessed by the NextCloud Client) with a web browser, I'm getting: "This XML file does not appear to have any style information associated with it. " followed by some XML output.

Unfortunately there is almost no documentation on the windows implementation and the very few articles I could find are conflicting on top. As is with the whole php config info which partially contradicts what is written in the php.ini comments of version 7.1...

Can you give me a hint how to get this to work?


Under review
server replied: Method not allowed

You need to fix your IIS configuration, find PHP under "Handler Mappings", double-click the entry, click "Request Restrictions...", switch to the "Verbs" tab and select "All verbs". Save the changes and restart IIS.

Sorry, checked that.

It's set correctly to "all Verbs".

Restarted Server anyway. Didn't change anything...

Look for other handlers that you might have and remove them if not needed, or disable them. The usual suspects are "WebDAV" and "OPTIONSVerbHandler".

Removed WebDav (wich was disabled anyway) and OPTIONSVerbHandler. Leaving PHP via FastCGI, PHP53 via FastCGI, TRACEVerbHandler and StaticFile. Still no change. Method Not Allowed

I suggest getting assistance from an experienced IIS server administrator, to check the server logs and identify the reason why your web server still rejects the WebDAV related HTTP requests.

With a default IIS configuration and a default PHP installation (installed using Web Platform Installer), allowing all the verbs on the PHP handler is generally all that it takes.

Hi, i had installed filerun in the windows environment also. i installed filerun using xampp in localhost. i get different issue. on weblink share, when i open the shared link it show blank page. i try to find the solution and an answer is remove the .htaccess file. i remove it but still blank page i got when shared link via weblink i open. any advice for this problem? thanks.

You are welcome to signup and start a new topic.

Server response: The FileRun installation cannot be registered to localhost.