Not a bug

Using network SMB share for data/file storage and map with UNC path

Matt V 5 years ago updated 5 years ago 2


I am trying to map a UNC path in FileRun. The directory fails to map, the only error being the standard "Invalid Folder!".

The network folder is a FreeNAS SMB share, with basic permissions. I have attempted to map the network drive on the Windows server to give it full permissions, but the same error occurs. I have also attempted to set permissions to the network share using Windows Active Directory "security" dialogue to give the IUSR (IIS Anonymous User) permissions to the directory, but with the same error. The server logs do not show the reason for the error.

Image 129

Image 130

Not a bug

UNC paths are not supported by FileRun.

For mapped network drives to be accessible by PHP, the HTTP server (IIS/Apache/etc) needs to run with a system user that has, by default, permissions to access the share. By default it doesn't. You would get better help with this challenge on the IIS user forum (https://forums.iis.net/).

Thanks for your help Vlad, I'll look into this more on the IIS forum and report back.