0
Under review

WebDav on Windows 10 cant upload Files (0x80070032) files are landing in Trash

martinhotmann 1 year ago • updated 1 month ago 5

I'm running the latest Windows 10 and the latest FileRun.

Everything is working fine, but when I want to upload files via WebDav (mounted as networkdrive) in Windows 10 this always throws me the error 0x80070032 With the message: "Die Anforderung wird nicht unterstützt".


I'm running FileRun on the latest Plesk on PHP 7.2.x.


Over the web (domain.tld/remote.php/webdav) I can upload, download and everything. But just when I use it as a mounted windows network drive I cant upload anything.


Does anyone knows how to fix that?


I mounted the Drive like this:

net use X: \\domain.tld@SSL\remote.php\webdav\

 everything works, also creating folders, but when I upload something it disapears and lands in trash. So noone can see/use it.



#EDIT:

btw mcrypt is not installed (also showed up while setup). But what wonders me is: 

mcrypt is deprecated since PHP 7.1 and will not work in PHP 7.2

and this FileRun installation is made for PHP 7.1.x and PHP 7.2.x !?


Best regards,

Martin

+1
Under review

I'm actually surprised that you managed to mount at all using the Windows' own quirky WebDAV support.


The official connection URL is:

net use X: \\demo.filerun.co@SSL\dav.php\@Home\

The one you use is dedicated to the Nextcloud apps, and there might be non standards-compliant behaviors in the future.


Uploading still doesn't work (technically it works, the file gets uploaded, then deleted, by Windows, as you can notice in the FileRun user activity log) but we'll look into it.


In the meantime, I suggest using a third-party tool, such as Netdrive or Webdrive for mounting FileRun as a Windows drive.


btw mcrypt is not installed (also showed up while setup). But what wonders me is: 

Thanks for pointing it out. It was probably forgotten in the installer, although FileRun doesn't need or use it.

Ok thank you, I solved my problems with FileRun using NetDrive.


There I just connectet to "https://domain.tld/dav.php/@Home" and everything worked fine!

map filerun webdav to windows 10 (copyright: propi62) ;)

1. rightclick in free space in my computer

2. add webadress

3. 

https://www.your-url.com/files/dav.php/%40Home/
(%40 is the @ sign)

Thank you for the information, we've added this method to the documentation: http://docs.filerun.com/webdav

Unfortunately it still does not seem to work uploading files using Windows 10 explorer. The culprit seems to be a call to PROPPATCH that returns a 501 error from Apache. Windows then deletes the uploaded file directly after this failed request. From my Apache log:

nnn.nnn.nnn.nnn - user [07/Mar/2019:19:53:28 +0000] "PROPFIND /dav.php/%40Home HTTP/1.1" 207 2604
nnn.nnn.nnn.nnn - user [07/Mar/2019:19:53:28 +0000] "PROPFIND /dav.php/%40Home/file.txt HTTP/1.1" 404 410
nnn.nnn.nnn.nnn - user [07/Mar/2019:19:53:28 +0000] "PUT /dav.php/%40Home/file.txt HTTP/1.1" 201 406
nnn.nnn.nnn.nnn - user [07/Mar/2019:19:53:29 +0000] "LOCK /dav.php/%40Home/file.txt HTTP/1.1" 200 760
nnn.nnn.nnn.nnn - user [07/Mar/2019:19:53:29 +0000] "PROPPATCH /dav.php/%40Home/file.txt HTTP/1.1" 501 400
nnn.nnn.nnn.nnn - - [07/Mar/2019:19:53:29 +0000] "HEAD /dav.php/%40Home/file.txt HTTP/1.1" 401 573
nnn.nnn.nnn.nnn - user [07/Mar/2019:19:53:29 +0000] "HEAD /dav.php/%40Home/file.txt HTTP/1.1" 200 465
nnn.nnn.nnn.nnn - user [07/Mar/2019:19:53:29 +0000] "PUT /dav.php/%40Home/file.txt HTTP/1.1" 204 393
nnn.nnn.nnn.nnn - user [07/Mar/2019:19:53:30 +0000] "PROPPATCH /dav.php/%40Home/file.txt HTTP/1.1" 501 400
nnn.nnn.nnn.nnn - user [07/Mar/2019:19:53:30 +0000] "DELETE /dav.php/%40Home/file.txt HTTP/1.1" 204 546

Is there any way to debug what causes this error? Apache error log is empty, so is PHP error log. Filerun log just says the file failed to upload.