0

Forced SSL - Need to revert

dennyhz 1 year ago • updated by Vlad R 5 months ago 5

How can I revert the "Force SSL" setting? Backstory below:


I had Filerun running just fine via HTTPS using NGINX reverse Proxy to my domain with a subdirectory for filerun. https://domain.something/filerun/


I stupidly checked the Force SSL button inside of Filerun and saved changes. Now when I go to https://domain.something/filerun/ I just get redirected to https://domain.something/ which is my primary domain address without the filerun subdirectory on it. I cannot access Filerun to uncheck Force SSL.


I can't even access my Filerun instance locally to revert this setting....when I go to my local Filerun IP address http://192.168.1.111:8585 I just get the following message:

"This software application is registered to a different server hostname."

And if I temporarily remove /system/data/filerun.dat and try to then access locally, I still cannot get in since it is forcing SSL regardless of $config['app']['api']['oauth2']['allow_over_http'] = true; setting in the customizables


Anyway to get this Force SSL setting unchecked somehow so I can get back to accessing the Filerun GUI?

Sorry if it was not clear, but I'm talking about the "Force users to access via HTTPS" setting under Misc Options. That is the setting I'm referring to.

Solved:


I had to jump through some hoops to finally access the Filerun GUI so I could uncheck the setting....but I got it.

Under review

Seems like the installation URL might not be detected properly with the particular reverse proxy setup. We'll look into it.

I also use a reverse Proxy (CloudFlare) and everything is working fine with SSL (also checked Force SSL).


Maybe your reverse Proxy is missconfogured or your SSL Domain is not set prooerly (dont know if there are two settings for the Domain like it is on Wordpress?) But I did not change anything special.

Well....Once I jumped through the hoops to access my FIlerun GUI, I could uncheck the Force SSL setting. After that, I am back to normal and able to access my FIlreun instance over SSL. I use namecheap. So, I'm not exactly sure why I can't check the force SSL setting......but I have SSL without that checked so it is sort of a non-issue for me now. Lesson learned

https://my.domain/filerun/