Not a bug

"Unexpected server reply" - error, when trying to login

Dr M 5 years ago updated by Vlad R 5 months ago 20


I keep having this message when trying to login on my filerun installation :

"Unexpected server reply. Press "OK" to display it."

No updates made recently, it happens depending on the browser used : mainly chrome and firefox (not all the time and for all versions, I have different users and configuration involved). I can't understand how and why it gives that bug. It seems that only IE can avoid this bug.

When pressing OK, page reloads otherwise nothing happens... I've been looking for a conflict with an extension... no success.

Any idea ?



Yes, I did it on Chrome 69 and 70 and I've found the problem source by switching off extensions one by one. Suprisely, Loady - Video and music downloader was the problem. 

Thank you for your help!

After some research, i located the problem with the js/login.js file near line 85

var responseText = frameDoc.body.innerHTML;
            if (responseText.length == 0) {
                return false;
            try {
                var rs = Ext.util.JSON.decode(responseText);
            } catch (er) {
                if (confirm(FR.T('Unexpected server reply. Press "OK" to display it.'))) {
                return false;

On first line var responseText = frameDoc.body.innerHTML;, responseText seems empty and therefore cannot be decoded.

Not sure but it might come from an iframe issue ? Is Chrome restricting using script inside iframe ?

Some help would be apreciated


The problem is related to a recent server update and affects only 2015 FileRun versions. The solution is to update to a newer FileRun version. At least 2016.

We tried, but there is no quick fix.


I have the same problem in a fresh installed 2018.05.22 version. 

Is there any fresh ideas to fix this issue?

Thank you.



Are you seeing any text/error after pressing OK? Do you have any errors logged to your PHP error_log?

It seems to me that there are no critical PHP errors in the log file.

Response string: {"success":"1","redirect_url":"https://server.address"}

It is only effected on Google Chrome version 69.0.3497.100 (64-bit).

Server Ubuntu 16.04.5 LTS
IE and Edge are OK.

I have tested the mentioned Chrome version and couldn't find any problem. Are you experiencing this with our demo as well? If not, then it's not a browser issue, but something is probably wrong with your particular FileRun installation.

I've tried your demo, and had the same problem as well: 


Still on Chrome 69.0.3497.100? Perhaps a browser extension that might cause this?


Yes, I did it on Chrome 69 and 70 and I've found the problem source by switching off extensions one by one. Suprisely, Loady - Video and music downloader was the problem. 

Thank you for your help!

Thank you for letting us know. Perhaps it will help others having the same problem. We'll check it out, maybe we can find a workaround for it.

I just noticed the same error on Chrome 79.0.3945.130 64bit. It only occured on enterprise version, not on free test environment. 

I am not confirming the problem. If you have a license with valid support service, I recommend you to e-mail us at tech-support@filerun.com so that we can troubleshoot your FileRun installation, which is where the problem is isolated.

the bug still exists,and when i log in,the screen always loops to the login screen( i have set the session_save_path).

And I can't login in until i've tried many times.

There is no related bug, it's only poor PHP configuration on your server. Please try again configuring. The correct configuration directive is "session.save_path" not how you wrote. Make sure it points to a valid folder path, which allows writing by PHP and the HTTP server. Make sure you have free available space in the folder.

Make sure you didn't mess the value of "post_max_size". If in doubt reset to default (2M).

This problem still exists. With a fresh Debian 11, latest PHP 7.4, and the latest FileRun. Browser used is the latest Safari. There are two cases:

  • if I set the session.save_path to ANY value, after inputting the credentials I get a message: "Communication with the server failed. Please try again later."
  • the other case is if I comment out the session.save_path parameter. In this case I get a message: "Unexpected server reply. Press "OK" to display it." If I press OK, a blank browser window appears, with a message: "{"success":"1","redirect_url":""}". But in this case I GET LOGGED IN in, just I have to close the newborn window and navigate to the site again.

This is insane. I've tried to install this stuff for 3 times now, all attempts failed. I can accept that "it's poor PHP configuration", but how to correct it?

You can't just use any random value for "session.save_path", or remove it completely. Where would PHP write the session data, then? :)

It needs to point to a valid folder, which allows PHP/HTTP to write to it. Try to set it to "/tmp". Note that PHP/HTTP might need restart for the PHP config changes to take effect.

By ANY I mean any sane path one would use. Eg. I created a /files directory in the very root of the drive. There are sub-directories named /storage (for data storage), /session (for session data), /temp (for temporary files) and /log (for logs). All this structure have 777 rights regarding www-data:

drwxrwxrwx 6 www-data root 4096 May 13 18:48 /files

drwxrwxrwx 4 www-data root 4096 May 16 20:10 /files/storage

drwxrwxrwx 2 www-data root 4.0K May 16 20:08 /files/session

drwxrwxrwx 2 www-data root 4.0K May 16 20:10 /files/temp

The filerun.ini has the needed lines:

session.save_path = /files/session

upload_tmp_dir = /files/temp

open_basedir = /var/www/html:/files

The directory which has all the FileRun install in it, has all the right privileges, too:

drwxrwxrwx 18 www-data root 4096 May 16 08:55 /var/www/html

Still, login is hindered by the message "Communication with the server failed. Please try again later." After clicking OK a blank browser page appears with the following: {"success":"1","redirect_url":""}. And if I reload the page now, I'm getting logged in as superuser. Very strange.

OK, I think I found the problem. There is a proxy working before this FileRun install, and I had to switch off the "Rewrite HTML" option. For anyone struggling with the same problem: try playing around with the router / proxy settings.