+1
Under review

Customizations and logo on top left bar?

alecormio 2 weeks ago • updated 5 days ago 16

Hello there, how / where I can add my logo (you can do it on the login by the settings, but doesn't show up as well on the top left as I can see from the screenshot in the home page) next to the  + NEW button, left side?

Plus, can I add like a button with a stati link as well in on the top right in case?


How about the icons? Can we customize them? I'm checking the docs, but somehow some steps are not that clear...


thanks in advance!


I'm trying to change the favicon as well, I don't have simply to replace the one in the root folder favicon.ico of filerun? Am I right? Coz I can't see any changes, shouldn't be a cache problem as I'm getting

Under review

Yes, it is as simple as that. Browsers tend to cache these quite hard and not refresh them very often.

There are no config options for what you are asking. So the only option requires custom web development. If you have the skills, you are free to explore the JavaScript and HTML source code and edit according to your wishes.

Thanks Vlad, well, a bit misunderstanding since U show this in the home page

Sorry, but the screenshot is from an older FileRun version and will be updated.

It's all in the css.  The top left logo is

/images/logo-38px.png

which css mate? style.css?

Even that logo-38px is not anymore in that folder. Maybe you're using an older version?


I don't get why they have decided to delete that, unfortunately.

I'd love to have the logo back in the top left corner as well.

Steps to get your custom logo back:

  • under Configuration > Interface >Branding, switch to custom theme
  • create customizables/theme.css (Help window says "customizables/custom_theme.css", but css/ext.php refers to customizables/theme.css
  • copy content of css/theme_blue.css to theme.css
  • add block $replaceColors to css/ext.php to get back the colored hover effects
  • instead, you could also include additional css code by following http://docs.filerun.com/custom_css
  • add your logo to the images folder
  • in your theme.css, add
    .headerTbar .x-toolbar-left-row::before {
        content: url("../images/logo.png");
        margin: 0 20px;
    }
  • to place your logo on the right side, use .headerTbar .x-toolbar-extras-row::after instead

Best regards, Patrick

Awesome thank you!


I couldn't figure out how to make colored hover effects work with $replacecolors in ext.php, but adding the headerTbar css for re-adding the logo worked perfectly. Appreciate the tips!

Ah, appreciate that. I see what you mean by adding the $replaceColors to the }else{.


Unfortunately even after making that change to the ext.php and copying the contents of css/theme_blue.css to customizables/theme.css & changing the Color Theme to Custom, it doesn't apply those colors to the highlighting. Instead it shows a grey theme no matter what HEX colors I apply to the replaceColors values.

It's like it's ignoring my theme.css.


For example, in my customizables/theme.css, I have...


/* Buttons */
.fr-btn-primary,
.fr-btn-primary.x-btn-over {
border-color: #4285F4;
background-color: #4285F4;
}


but when I use Chrome Dev Tools to inspect css/ext.php?v=2018.05.22&theme=custom


/* Buttons */
.fr-btn-primary,
.fr-btn-primary.x-btn-over {
border-color: ;
background-color: ;
}





Actually looking at it closer, it's striping out all the hex color codes from my theme.css. Here's that portion of my css/ext.php?v=2018.05.22&theme=custom when viewed with Chome Dev Tools. No color codes at all.


https://pastebin.com/HYGV7BBB

Sad to see this feature go. Don't know why? That was a feature and not a bug...