0
Not a bug

Avatar Not Show AND Share To Download Error

duyhandsom210 2 years ago updated by hamid 9 months ago 8 2 duplicates

Hi.

I trying to use filerun before buy. But i got 2 issues.

1. I install successful on my localhost. but why all avatar of 3 user not show.
2. Also when i right click a file and share web link. open new private window but it seem doesn't work.
the URL look like : mydomain.com/wl/?id=BF8MziMozS9X5f8q0LFKYPEos3MCwCm2

thank you 

Answer

Answer
Under review

1. Do make sure you have PHP GD library enabled: http://php.net/manual/en/image.installation.php

2. Do provide more details (at least the message) about the error.

Duplicates 2

Answer
Under review

1. Do make sure you have PHP GD library enabled: http://php.net/manual/en/image.installation.php

2. Do provide more details (at least the message) about the error.

1. Thank you. it resolved.
2. It show blank page have nothing no message inside. how to open debug or st to display error. 
thank in advance

Any entries saved to the PHP configured "error_log"? (For PHP to log errors, "log_errors" must be set to "On" in the PHP configuration.) Alternatively, making sure "display_errors" is set to "On" in the PHP configuration could have some details displayed instead of the blank page.

Sorry to bring this up again. But what if the GD Library is enabled, but the user avatars are still broken? The server is running linux, PHP 7.0 and is being hosted by 1and1. And there isn't much I can do to edit the PHP configs other than change the php.ini and change its version (5.6, 7.2, etc.) for directory that Filerun is on. 

Regards,
Brian

Not a bug

Please check if you have the option "Use Gravatar.com for users profile images." enabled (under "Third Party Services") and perhaps try to disable it to see if it makes and difference.


Also check that the folder "system/data/" and all subfolders are writable by PHP (chmod 777 if unsure - just to see if it makes a difference).


And lastly, there should be some related error messages logged to the configured PHP "error_log". That information would really help solving this.

Hi Vlad,

I followed your instructions and checked php.ini and log file. Unfortunately, I still have the same problem. log file does not show anything and phpinfo is showing  that gd library is enabled.

Is there any way that I can just set a permanent image instead of an avatar?  


Kind Regards,

Hamid 

Users can upload their own images through the Account Settings panel.

I tried it but still, it shows nothing and it does not appear on the account setting as well.