+1
Answered

Missing thumbnails and no metadata

marcpalaus 6 months ago • updated by Vlad R 6 months ago 6

I just installed FileRun for the first time. I already have a picture collection of around 100000 photos which have been tagged and classified in albums (folders). I intend to use FileRun as a way to search pictures based on tags.


So, I added my path and I can browse the directories with my pictures, but most of the pictures do not show a thumbnail, although if I double click on them, I can see the full picture. In addition to that, no metadata or tags are shown. In the sections at the bottom, where you can browse pictures by tag, by date or by Last taken, it's just empty.


Also, I tried indexing (right click, "More options"  -> "Index files"), and a little window opens with this message:


{"rs":false,"success":false,"msg":"Your user account does not have permission to perform the requested operation!"}

What am I doing wrong?


Thanks in advance.

Answer

Answer

Ok! Solved!


First of all, I used the metadata_index.php script and it scanned all the metadata successfully (it took a few minutes, but it's relatively quick). So Tags and Dates are now populated. I can run a cron job every night to scan and update the metadata if necessary.


Second, regarding the thumbnails, I created a folder to store all the thumbnails in the filebot directory instead of the default locations (on each path root?). now I keep them at /var/www/html/filerun/thumbnails/, and I edited the /var/www/html/filerun/customizables/config.php with the following content:


<?php
    $config['path']['thumbnail_cache'] = '/var/www/html/filerun/thumbnails/';
    $config['app']['thumbs']['output_small_filesize'] = 15728640;
?>


So far, it seems to generate all the thumbnails correctly. You can close this issue if you with.

Under review

For thumbnails, you need to configure FileRun with ImageMagick: http://docs.filerun.com/imagemagick#setting_up_filerun


For indexing so many files I can image it will take a while, so I suggest using the command line script "metadata_index.php" for it. You will find more details here: http://docs.filerun.com/command_line_tools


P.S. I haven't seen that message before related to the indexing option. You can try our demo to see how it is supposed to work. If you contact us (https://filerun.com/contact) privately and can provide a demo to your installation, it would help us understand what goes wrong to see if it's a bug that needs fixing.

Also, for indexing metadata, make sure your PHP has the EXIF and XML extensions enabled.

Thanks for your response.


Imagemagick is enabled (Version: ImageMagick 6.9.7-4 Q16 x86_64), but even if I disable it, some thumbnails are generated, others don't (most don't). php extensions for Exif and XML are enabled:


root@box-media:/var/www/html# php -r "print_r(get_loaded_extensions());"
Array
(
    [0] => Core
    [1] => date
    [2] => libxml
    [3] => openssl
    [4] => pcre
    [5] => zlib
    [6] => filter
    [7] => hash
    [8] => pcntl
    [9] => Reflection
    [10] => SPL
    [11] => session
    [12] => standard
    [13] => mysqlnd
    [14] => PDO
    [15] => xml
    [16] => calendar
    [17] => ctype
    [18] => curl
    [19] => dom
    [20] => mbstring
    [21] => fileinfo
    [22] => ftp
    [23] => gd
    [24] => gettext
    [25] => iconv
    [26] => json
    [27] => ldap
    [28] => exif
    [29] => mysqli
    [30] => pdo_mysql
    [31] => Phar
    [32] => posix
    [33] => readline
    [34] => shmop
    [35] => SimpleXML
    [36] => sockets
    [37] => sysvmsg
    [38] => sysvsem
    [39] => sysvshm
    [40] => tokenizer
    [41] => wddx
    [42] => xmlreader
    [43] => xmlwriter
    [44] => xsl
    [45] => zip
    [46] => Zend OPcache
)


For some reason, when I try to run "metadata_index.php" from the command line, it complains that the ioncube PHP loader is not installer. However, when I check phpinfo() in the browser, ioncube is loaded. -


EDIT: Nevermind, I added the following line

zend_extension = /usr/lib/php/20151012/ioncube_loader_lin_7.0.so

to the /etc/php/7.0/cli/php.ini file and now ioncube is recognized from the command line.

+1

If you see the following message:


{"rs":false,"success":false,"msg":"Your user account does not have permission to perform the requested operation!"}

It means you have unchecked the permissions option "User can make changes to files and folders" for the Superuser account.

If you wish to have a read-only user account, I suggest creating a separate one, as the Superuser needs that permission in order to access the indexing function.

Answer

Ok! Solved!


First of all, I used the metadata_index.php script and it scanned all the metadata successfully (it took a few minutes, but it's relatively quick). So Tags and Dates are now populated. I can run a cron job every night to scan and update the metadata if necessary.


Second, regarding the thumbnails, I created a folder to store all the thumbnails in the filebot directory instead of the default locations (on each path root?). now I keep them at /var/www/html/filerun/thumbnails/, and I edited the /var/www/html/filerun/customizables/config.php with the following content:


<?php
    $config['path']['thumbnail_cache'] = '/var/www/html/filerun/thumbnails/';
    $config['app']['thumbs']['output_small_filesize'] = 15728640;
?>


So far, it seems to generate all the thumbnails correctly. You can close this issue if you with.

Answered

Great to hear that things are working fine for you now!