0
Not a bug

Thumbnails not working properly

Shadow 3 months ago • updated 1 month ago 4

I'm currently trying to get thumbs working but there seem to be a few issues.

I'm running FileRun on Windows Server 2016 with IIS and FastCGI.


At first I added the path ("C:/Program Files/GraphicsMagick-1.3.30-Q8/gm.exe") to the gm.exe into the config which was checked and valid. As there were still no previews were loading I tried running the make_thumbs.php. Following error was apearing there:

4  D:/Cloud/Users/Superuser/DSC03430.JPG......................C:/Program Files/GraphicsMagick-1.3.30-Q8/gm.exe: Unrecognized command 'size'. Use -help for a usage summary or see manual..
...OK


GM Version: GraphicsMagick 1.3.30 2018-06-23 Q8

So I figured that FileRun is not passing the right options to the gm.exe. It looks like the convert part infront of the options is missing. http://www.graphicsmagick.org/GraphicsMagick.html


So after that I tried ImageMagick and partially succeded. First thing missleading is the documentation (http://docs.filerun.com/imagemagick) that asks you to add the path to the convert.exe which doesn't exist in the current version of ImageMagick 7.0.8. So I set it to "C:/Program Files/ImageMagick-7.0.8-Q8/magick.exe" and thumbnails were loading.

Next I installed Ghostscript 9.25 and tested if it was working with ImageMagick, which it was. Back in FileRun I had to notice that existing pdf files couldn't load thumbs. When I ran the make_thumbs.php scripts again it was working fine for some reason. So pdf thumbs somehow can only be generated via the script and not by uploading files or opening the folder they're in.


All of this works fine on the demo server so I'm wondering if I'm doing something entirely wrong here or am I just using current versions that are not fully compatible with FileRun?


To summarize this, I think the documentation about that topic could use some updating as well as the implementation of GraphicsMagick.

Answer

Answer
Not a bug

I finally found out what the problem was. Ghostscript uses the systems temp folder which the IUSR, that php scripts are running as, doesn't have access to by default. Granting Read/Write permissions on that folder fixed the issue for me.

That also explains why running the make_thumbs.php worked fine as it was then running as a different user.

GraphicsMagick still doesn't work at all for me. make_thumbs.php is throwing following error:

D:/path/filename.PDFC:/Program Files/GraphicsMagick-1.3.30-Q8/gm.exe: Unrecognized command 'density'. Use -help for a usage summary or see manual..

You may mark this topic as answered/fixed but please rework the docs entry about this, it is really outdated.

Under review

Given that it works via the command line but not via the web server, you might want to manually add the path of your Ghostscript installation to the Windows "PATH" environmental variable. (It probably requires a restart for it to take effect.)

It is very possible that those particular program versions for IM and GM have not been yet tested with FileRun. Will push this to development for checking and get back with the results.

Thanks for your answer.

I added C:\Program Files\gs\gs9.25\bin and C:\Program Files\gs\gs9.25\lib to my System Path Variable and restarted the server but pdf thumbs still don't load. Is there any log I could have a look at to see what's going wrong?

So, any updates on this? Still can't get it to automatically generate pdf thumbs.

Were you able to replicate this issue or might it be something with my specific setup?

Answer
Not a bug

I finally found out what the problem was. Ghostscript uses the systems temp folder which the IUSR, that php scripts are running as, doesn't have access to by default. Granting Read/Write permissions on that folder fixed the issue for me.

That also explains why running the make_thumbs.php worked fine as it was then running as a different user.

GraphicsMagick still doesn't work at all for me. make_thumbs.php is throwing following error:

D:/path/filename.PDFC:/Program Files/GraphicsMagick-1.3.30-Q8/gm.exe: Unrecognized command 'density'. Use -help for a usage summary or see manual..

You may mark this topic as answered/fixed but please rework the docs entry about this, it is really outdated.