0
Solved

Sharing file get blank page

pascal_von 1 year ago updated by molnarb83 1 month ago 24
I have installed Filerun on windows server 2016 and getting a blank page when a file is shared

Answer

Answer
Solved

The problem can be caused by the "include_path" setting. It needs to include "." in the list of paths, like this:

include_path = ".;C:\xampp\php\pear"

Note for Linux users, the path separate should be a colon (:). Windows users need to use a semicolon (;).

Under review
Are you able to download files normally via the FileRun user interface?
Yes am able to download files from FileRun interface.
Am I missing something after installation? It works good on Linux ubuntu but having a blank page on windows server 2016. I am using  XAMPP.
Any errors logged to the PHP configured "error_log"?

Did you solved the problem? Same here.

Same problem here... any solution?

OS, HTTP server and version, PHP version, error_log entries, please.

Windows 10, XAMPP 3.2.4, Apache/2.4.41 (Win64) OpenSSL/1.1.1c PHP/7.3.11

and I don't know where can I find the error log entries. :(

Just to make sure I understand correctly the problem, you are right-clicking a file, selecting "Share", then "Wb link" and the link you are getting, if click "Open", you are just getting a blank page?

Yepp. :( So I can't share anything at the moment. :(

The errors should be logged inside the file you have configured as "error_log" in the PHP configuration file (php.ini).

You should also look in the XAMPP logs.

There's no errors at the logs or I can't find :(  Can you help via remote desktop or something?

Only if you purchase an Enterprise license: https://filerun.com/enterprise

So free users accept that it is wrong or maybe some bug or problem somewhere... thx :( Anybody else? Or the first user? pascal_von or anybody solved the problem?

Looks like you are accepting that you are unable to provide logs from your server...


But I can't find anything in the logs or maybe I look for it at bad folder

Hopefully you can find the "php.ini" file and set "display_errors" to "On" and restart the HTTP server. to see the actual error instead of the blank page.

Same here... display errors on... restarted... no error message...

Rename the file "wl/.htaccess" to anything else and let me know if there's any change.

Nope... If I rename the file... nothing happening... the problem is the same (after reboot of course)

Please download this file "https://goo.gl/ens592", upload it to your server and send us its URL or output. I will check the PHP configuration for you to see if there's something there that might cause this.

Answer
Solved

The problem can be caused by the "include_path" setting. It needs to include "." in the list of paths, like this:

include_path = ".;C:\xampp\php\pear"

Note for Linux users, the path separate should be a colon (:). Windows users need to use a semicolon (;).