0

Desktop client can't sync on IIS FR Server

razor-thrent 6 months ago • updated by Vlad R 4 weeks ago 16

Hello everyone,

I'm currently setting a home filerun server, and managed to make it run pretty well, except for one single part, the nextcloud sync client...

The server has been setup on a Windows Server 2012 R2, IIS 8.5, PHP-CGI 7.2.2, MySQL Server 8.0. SSL is enabled thanks to LetsEncrypt, and with some tweakings, I managed to make the Website work at 100%, and so is the filerun app on Android.

But the Nextcloud client, he fail to synchronize files. The initial connection succeed, the detection of the folder tree is working, but sync error :


I tried 3 others versions of nextcloud, owncloud and such. Always a unknown error. I made a lot of tweakings of my own and of internet search (that I lost count of) without success. The file permission IUSR is set, even tried to "everyone". I suspect it's a webdav issue, but I'm out of solutions.

I know I won't have that kind of trouble on a linux server, but for multiples externals reasons, I need to make it works on a WS.

I thanks you all in advance for the help you could provide.

Under review

Try to access "https://your-filerun-url/dav.php/" in a web browser. You should be prompted to login. After providing the FileRun user credentails you should see an XML page. Let me know what you get instead.

Also, do specify the Nextcloud app version.

Nextcloud version : 2.3.3. Il also tried the 2.5.1. Here's the XML :

<multistatus xmlns="DAV:" xmlns:oc="http://nextcloud.org/ns"><response><href>/dav.php/</href><propstat><prop><displayname>ROOT</displayname><creationdate>2018-12-22T12:47:41+01:00</creationdate><getlastmodified>Sat, 22 Dec 2018 11:47:41 GMT</getlastmodified><getetag>ec2be98374458046a90a6a692093f9dc</getetag><resourcetype><collection/></resourcetype><iscollection>1</iscollection><isFolder>t</isFolder><lockdiscovery/></prop><status>HTTP/1.1 200 OK</status></propstat></response><response><href>/dav.php/%40Home/</href><propstat><prop><displayname>@Home</displayname><creationdate>2018-12-22T12:47:41+01:00</creationdate><getlastmodified>Sat, 22 Dec 2018 11:47:41 GMT</getlastmodified><getetag>ec2be98374458046a90a6a692093f9dc</getetag><oc:permissions>DNVW</oc:permissions><resourcetype><collection/></resourcetype><iscollection>1</iscollection><isFolder>t</isFolder><lockdiscovery/></prop><status>HTTP/1.1 200 OK</status></propstat></response></multistatus>

Things look good, so not sure what could cause this. Same error when selecting just a subfolder or just the home folder?

Yes, totally same error. I can navigate my whole folders tree, but not sync files.

Does your desktop app work with our demo server? (https://demo.filerun.co/) Just to rule out any client app-related issue.

I've made additionnals tests with a blank account :

  • When adding files in the nextcloud client, I can't upload files and folders because "Not allowed, you have not the permission to add subfolders in this folder", or "Not allowed to add files in this folder".
  • On the website interface, I can create files and folders. But I can't upload any files : "Data transfer failure, Make sure you don't send an empty folder".

On the server, files permissions are set to everyone (777 equivalent, for testing purpose). Is the data location correct ?

My root FileRun Website is E:/WebSites/FileRun . Data are stored at E:/WebSites/FileRun/data .

Or is there anything else ?

Okayyyy. I had fun with that one.

The main problem source seems to come from php.ini file variables, "open_basedir" and "upload_tmp_dir". Somehow, these 2 were in conflicts, and the uploaded data were sent to a still unknown folder without right permissions (in this case, Windows IUSR account). Which explain the lack of logs.

I had to set "open_basedir" at default values to make the magic happen.

Now I can upload files, and use nextcloud client (with the help of this topic) to start syncing data. I have some e-tag errors showing, but as the upload is in progress, I'll wait till it finish to conclude.

Back to square one and a half this morning...

Web interface is OK. Upload work fine, and others stuffs. But desktop client can't sync files anymore again., showing an unknown error.

Tried the 2.5.1 client, same result, but with an HTTP transmission error, missing data at file discovery.

It would help if you could send over the app's log file. It gets saved as a hidden file inside the sync folder.

Well, the log don't speak much. ^^'

Here Initial Upload (Server didn't confirm reception of last "piece" (no E-tag). The file were uploaded neverthless

And here Continuous Upload (Error Unknown) Folders are synced, but not the files

Thanks. Server patched, but the issue still going.

BUT, I maybe have an interesting clue.

I redid the upload, but folder by folder, almost file by file. The issue seems happening when files contains "è" or "ê" in his name (We have a beautiful language doesn't we ?). When it's happen, the file is uploaded with the "e-tag" error; then the desktop client stop syncing with "unknown error". I have to delete the files and folder on server and client side to make nextcloud work again.

Here's the log : .owncloudsync.log

Look for Prêt_auto.pdf and pièces.txt in the log.

Without that kind of files, the sync works well (except if I create files & folders in the @home folder, no permissions).

EDIT : Probably others characters involved... Furthers tests needed...

If you upload a file to the server, with accented characters in its name, from FileRun's web interface, does the desktop sync app downloads it fine?

"Server error: PROPFIND reply is not XML formatted!" on Nextcloud client.

I confirm that this behavior is going on every accented folder, and files (files may have a delay before having an error).