0
Answered

Issues with arm64/aarch64

Shadow 5 months ago • updated 5 months ago 8

Hey,

I recently got a rock64 sbc which I want to run FileRun on. It runs on a ARMv8-A RK3328 ARM ARM Cortex-A53 quadcore and 4Gb RAM armbian(debian 4.4.162). My first problem was that there is no ionCube loader provided for that architecture, but the support could provide me a compatible version (10.2.5) that I was able to load. phpinfo() confrims that

The next issue came up when I tried to run FileRun for the first time. The browser connection fails and the apache error log shows a segmentation fault. gdb backtrace shows a corrupt stack while the last tracable function is zend_compile_string(). strace ends after loading /customizables/config.php; if it helps I can provide both trace files in case that helps which i doubt.

I'm desperately searching for a solution because I really like FileRun and don't want to switch over to nextcloud which I know would run fine. Obviously ionCube loader is the issue here and not FileRun but I'm just hoping that anyone here has an idea how to fix this. ionCube support is currently trying to reproduce the issue, fingers crossed.

I'd also like to try loading other websites that use ioncube, so I can tell the support that the issue is not FileRun but I couldn't find any.

Answer

+1
Answer

Today I received a new loader version 10.3.2 from the support that works like a charm. If you need one just open a ticket at https://support.ioncube.com/index.php?

You may flag this as completed.

Under review

FileRun does not ship by default with a "customizables/config.php". Try removing it.

You are right this file doesn't belong there it was just a leftover from my previous installation from Windows. But I also tried a fresh install that doesn't have a config.php and it doesn't work either. It's just that I wasn't able to debug the fresh install at all because I can't execute it via CLI and when accessing it thru apache there is no coredump created for whatever reason. I belive that's because the problem is a low address/null pointer reference that gdb and coredump have issues with, hence the corrupt stack on backtrace.

I have somewhat given up on debugging this myself, even though I'd really like to stay with FileRun I guess I'll have to switch over to Nextcloud temporarily until ionCube provides a stable loader for aarch64.

I was able to install Filerun on the first Raspberry Pi running on a ARM cpu too, and could find incube for this cpu. Strange to not find one for you :/

You are right, for the Raspberry Pi2 B they do provide a ARMv7 32bit loader. But the rock64 runs on a ARMv8-A architecture so I can't use the loader they provide on their download page. As I said the support was so kind to send me a dev-build loader for my system. For some reason that one doesn't work so I'll just have to wait and hope that they fix it anytime soon.

+1
Answer

Today I received a new loader version 10.3.2 from the support that works like a charm. If you need one just open a ticket at https://support.ioncube.com/index.php?

You may flag this as completed.

Answered

Thank you for letting us know.

I am also facing the same problem with the architecture. I am using an Orange pi zero plus and from what i understand its x64 bit. But there is no ioncube loader available. Can you send me the loader in case it work. Because we have the same cpu

I'm sorry but I can't send you the loader. First I'm quite sure I wouldn't be allowed to distribute it, second people contacting their support about it is the only way for them to assess the demand for a arm64/aarch64 loader.

So please just open a ticket on their support page (link above). I was very pleased with their support, they had a very short reply time and were all competent.

Make sure to include a *.html save of your phpinfo in the request so they can provide you the right version.