0
Answered

error transferring :method not allowed

maple.he 2 years ago updated 1 year ago 7

Hello:

I'm using windows sync client connect my server. but it show error:

I'm using IIS with PHP7.

the error shows on ios app too.(fe file explorer)

what's wrong with my server?

Answer

Answer
Answered

Step 1: Open IIS Manager

Open the Start menu and type "IIS" in to the find box. You should see an application called "Internet Information Services (IIS) Manager".

Step 2: Select your computer in the "Connections" pane

On the left, there is a "Connections" pane. You should see your computer listed here. Click on your computer name which should load the a dashboard with a handful of icons.

Step 3: Open PHP Handler Mapping

Double-click on the Handler Mappings icon to bring up the Handler Mappings screen.

Then double-click on the handler for PHP files to bring up the "Edit Module Mapping" window:

Step 4: Edit Verbs

Click on the "Request Restrictions" button, then switch to the [Verbs] tab. Switch the radio button to "All Verbs", then click "OK" to close the window, then "OK" again to close the other window.

Answer
Answered

Step 1: Open IIS Manager

Open the Start menu and type "IIS" in to the find box. You should see an application called "Internet Information Services (IIS) Manager".

Step 2: Select your computer in the "Connections" pane

On the left, there is a "Connections" pane. You should see your computer listed here. Click on your computer name which should load the a dashboard with a handful of icons.

Step 3: Open PHP Handler Mapping

Double-click on the Handler Mappings icon to bring up the Handler Mappings screen.

Then double-click on the handler for PHP files to bring up the "Edit Module Mapping" window:

Step 4: Edit Verbs

Click on the "Request Restrictions" button, then switch to the [Verbs] tab. Switch the radio button to "All Verbs", then click "OK" to close the window, then "OK" again to close the other window.

phpinfoI'm already set the radio button to "All Verbs",but still have this error.

here is my phpinfo.

This is not a PHP issue, but an IIS one, so phpinfo() is not of much help. If you have made the change, perhaps you didn't restart IIS.

I'm already restart the iis.

but still have this question.

Is there any other setting?

Does webdav need to set anything?

I modified the WebDAV rules and now it can connect.

but it show other error: Not Found.

Follow the steps below to successfully use NextCloud Sync.


1.Open WebDav Authoring Rules and then select Disable WebDAV option present on the right bar.
2.Select Modules, find the WebDAV Module and remove it.
3.Select HandlerMapping, find the WebDAVHandler and remove it.
4.Restart IIS.

Windows iis information is really too little. I almost gave up on this.