0

Enable nginx X-ACCEL for an entire drive

Dragoon 11 months ago updated by Vlad R 11 months ago 3

I want to use X-ACCEL to speed up downloads (currently maxing out at 60-70MB/s on local network, nginx direct downloads saturate gigabit connection), but I've been unable to make it work properly.

I use Stablebit's DrivePool software to combine several large drives into one big virtual drive, D:/. I've set my user home directory as the root of D:/, this gives me access to all of the drive and I can share specific folders with friends. However, some files are quite large (50+GB).

Currently using nginx as a reverse proxy pointing to an apache2 instance running RileRun. I believe I can enable X-Accel using 

Internal; 

root d:/; or alies d:/;


but this prevents access to the web interface entirely.

Any ideas? I'm open to switching to a different reverse-proxy like Caddy if it will solve my issues.

If your FileRun instance runs on Apache then you should use "mod_xsendfile". Why would you be running a reverse proxy on the same machine?

nginx was already being used to provide SSL for two other websites, so I had to add apache+FileRun to it.

A pretty good reason.

You should see the following post: https://feedback.filerun.com/communities/1/topics/411-this-site-cant-be-reached-share-web-link-problem-with-download-accelerator#comment-1262

The Nginx configuration should be complete with the "location" part.

I see no reason why it shouldn't work for you.