0

Delete Cache / Reindex

isaac 2 years ago updated 1 year ago 6

Hi,

I've thousands of users, and needed to change the path URL for all users. I used phpMyAdmin to access the table "df_users_permissions", and I modified the "homefolder" path of all users.

Now when I try to edit a user or add a new user I usually get: "An error was encountered while trying to load the data from the server".

I was thinking that maybe if I clear the system cache or re-index the database, the issue will get resolve. Is there a way to do it?

Last, I see no place to see the system full error log. Is there a way to see it?

By the way, users can continue to login, and download their files with no issue.

Thank you

FileRun does not cache the folders listing. If folder paths changed in your system, you should use this guide: http://docs.filerun.com/migrating#the_user_files

Thank you for the quick reply. 


I've used phpMyAdmin to change the path. Users can continue to download files after the change, so I guess the change of the path using phpMyAdmin was OK. However, when I try to edit a user in FileRun I get the "Loading" for about 200ms, but nothing happens. After clicking the edit button for about 10 times, it sometimes open the user, and I can make changes. Also, sometimes I get the "An error was encountered while trying to load the data from the server" when I try to open a user or add a user or when I click to refresh the users list.

Does the system keeps an error log (I couldn't find)? Maybe I would be able to get more info. Maybe you have some other ideas how to resolve this.


Thanks again

Hi Vlad,

Thank you for the advice. I checked the error log, and here is the error that comes up every time I try to edit a user through File Run admin interface:

client denied by server configuration: /home/example/public_html/a/, referer: https://example.com/?module=cpanel&_popup_id=popups_1

Do you have a suggestion how to fix such an error?

If you are running Apache with mod_security, try to disable mod_security to confirm that one of its rule is not good and triggering a false positive.

Hi Vlad,


I've disabled mod_security & restarted Apache. Error still exist. Therefore, I enabled mod_security again.

I also noticed another error in the error log:

AH00124: Request exceeded the limit of 10 internal redirects due to probable configuration error. Use 'LimitInternalRecursion' to increase the limit if necessary. Use 'LogLevel debug' to get a backtrace.

Thank you for your help