0
Not a bug

Cannot connect with desktop application, mobile app is working

Sylvain Pichon 3 days ago • updated by Vlad R 17 hours ago 7

Hi,

I host a filerun instance, installed on a server using cpanel/softaculous.

The web interface is working correctly as well as conection using Android application.

However the desktop clients (tried on both windows and linux) won't connect: I just get a "connection closed" message.

Still, it works with your test server.


I can also access https://......../dav.php URL that redirect me to an XML file once my credentials entered.


Any idea?


Thanks!
 

Under review

The connection URL should be the simple URL of your FileRun installation (same URL you use in the browser), not with "/dav.php" or anything else after the folder URL. Could that be it?

I was talking about dav.php because this is oneof the  recommended test to be done on this forum :-)

Same for the test server.

Otherwise, yes I'm using the same URL than in my browser.

Here is the client error I get:

04-16 08:36:02:091 10468 OCC::AbstractNetworkJob::slotFinished: void OCC::AbstractNetworkJob::slotFinished() QNetworkReply::NetworkError(RemoteHostClosedError) "Connexion fermée" QVariant(Invalid)

04-16 08:36:02:093 10468 OCC::PropfindJob::finished: PROPFIND request *not* successful, http result code is 0 ""

No error log at server side.

No problem with the Android application nonetheless, do you know what diffenrences between this app and a desktop client regarding the connection method?

Thanks!

You should actually try a WebDAV client, to connect, browse folders, download files, not just trying the WebDAV URL in a browser, because I have a feeling it will not work for you. You should check your HTTP access and error log, as it is possible that your HTTP server is rejecting PROPFIND requests.

I tried to connect my site as a network drive and it does not works.

Is it ok as a WebDav client test?

Here is PHP parameters that I can modify on my server:

allow_url_fopenOn
allow_url_includeOff
always_populate_raw_post_datano value
auto_prepend_fileno value
curl.cainfono value
date.timezoneEurope/Paris
default_charsetUTF-8
default_socket_timeout60
disable_functionsno value
display_errorsOn
error_log/home3/cussou/logs/php_errors.log
error_reportingE_ALL
expose_phpOn
file_uploadsOn
html_errorsOn
include_path.:/opt/alt/php72/usr/share/pear
log_errorsOn
mail.force_extra_parametersno value
max_execution_time30
max_file_uploads20
max_input_time-1
max_input_vars1000
memory_limit128M
opcache.max_accelerated_filesno value
opcache.memory_consumptionno value
opcache.validate_timestampsno value
open_basedirno value
output_buffering4096
post_max_size8M
realpath_cache_size4096K
realpath_cache_ttl120
register_argc_argvOff
register_globalsno value
register_long_arraysno value
serialize_precision100
session.cookie_domainno value
session.cookie_httponlyOn
session.cookie_lifetime0
session.cookie_secure0
session.gc_divisor1000
session.gc_maxlifetime1440
session.gc_probability1
session.save_path/opt/alt/php72/var/lib/php/session
session.use_trans_sid0
short_open_tagOn
upload_max_filesize2M
upload_tmp_dirno value
zlib.output_compressionOff

And the .htaccess (root of my Filerunserver) content:

<IfModule mod_rewrite.c>
    RewriteEngine on
    RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization},L]
</IfModule>
SetEnvIf Authorization "(.*)" HTTP_AUTHORIZATION=$1

<IfModule mod_php5.c>
   php_value error_reporting 22519
   php_flag allow_url_include 0
   php_flag allow_webdav_methods 1
   php_value memory_limit 256M
   php_value max_execution_time 300
   php_flag output_buffering 0
   php_flag zlib.output_compression 0
   php_flag file_uploads 1
   php_value max_file_uploads 10
   php_value upload_max_filesize 20M
   php_value post_max_size 20M
   php_flag enable_dl 0
   php_value default_charset 'UTF-8'
</IfModule>
<IfModule mod_php7.c>
    php_value error_reporting 22519
    php_flag allow_url_include 0
    php_flag allow_webdav_methods 1
    php_value memory_limit 256M
    php_value max_execution_time 300
    php_flag output_buffering 0
    php_flag zlib.output_compression 0
    php_flag file_uploads 1
    php_value max_file_uploads 10
    php_value upload_max_filesize 20M
    php_value post_max_size 20M
    php_flag enable_dl 0
    php_value default_charset 'UTF-8'
</IfModule>

<IfModule mod_dir.c>
  DirectoryIndex index.php index.html
</IfModule>

AddDefaultCharset utf-8
Options -Indexes

The php_error.log file only contains this:

[16-Apr-2019 20:47:43 Europe/Paris] PHP Deprecated:  Function create_function() is deprecated in /home/cussou/public_html/photos/include/config_default.inc.php on line 390

Thanks again for your help

Windows is finicky and does not provide a meaningful error message on failure, do try WebDrive or NetDrive (http://docs.filerun.com/webdav).


The PHP configuration looks fine and there isn't much there that can affect WebDAV.

The logged PHP error is not from FileRun.

Hi, 

I had a discussion with my web host, and it's an issue at their side.

In fact owncloud/nextcloud is not supported and I shouldn't have been able to setup a Filerun server, they removed it from their offer.

This topic can be closed.

Thanks