0
Answered

ImageMagick troubles

dorin.muntean 10 months ago updated by Vlad R 7 months ago 9

Hello,

I have a problem with generating thumbnails. ImageMagick 7.0.8-37 Is installed and enabled. But when I open a folder with pictures, a thumbnail is generated only for those pictures that are lower than 2MB.


Is there a option where I can raise this limit? 

And when I open pictures in the viewer, that are larger than 2mb (for example 10mb) only the "pictures symbol" shows up (like at the thumbnails). But when I zoom in, the preview is immediately loaded?!

I'm on the filerun version 2019.05.21

thanks

Under review

I have renamed the topic to make more accurate to the problem description.

FileRun does not use ImageMagick or does any processing to small image files. The thumbnails are the files themselves.

If you don't get thumbnails for files that FileRun is actually using ImageMagick with, it means one of the two: 1) ImageMagick doesn't work, 2) PHP doesn't have write permissions to the browsed folders (which it needs for writing the thumbnail cache)

I'm having the same issue. ImageMagick appears to be working (see image). Regarding permissions, I created a directory within the filerun directory called "users", and I created one directory in there for each of my 3 users - all these directory are owned and grouped to the same owner and group as the rest of the filerun files, and all of these directories have 775 permissions (I'm on an ubuntu 18.04 shared server). I noticed some of the image files in these folders had 644 permissions, so I changed them to 755 but still I'm not getting thumbnails for them. I even changed them to 777 but still not luck. Any suggestions?

UPDATE: The images DO now display thumbnails now that I changed permissions to 775. It just took a while for the change to take effect. This is the 2nd time I've seen this delay with FileRun - after I make a change I test it, including closing the tab and browser, reloading the page, etc., but no luck until after 5 or 10 minutes when it suddenly makes a difference. Maybe has something to do with caching. Anyway, I can confirm that permissions were preventing FileRun from displaying thumbnails for some images. 

You can also configure FileRun with an external location for the thumbnail cache. See $config['path']['thumbnail_cache'] on this page.


P.S. PHP configurations or file permissions are not something FileRun would or could cache. If you are running on a shared hosting service: some providers implement their own aggressive caching on the filesystem for optimizing their hardware resources.

I've had nothing but problems with ImageMagick and when I was finally able to get it to do something under FileRun on my Windows Server, it was very slow.  I switched to GraphicMagick and everything instantly just worked!

Thank you for the help! For me it was a permission error. I changed the data folders to 775, and now it works thank you!

Hi i ve upgrade to ImageMagick 7.0.8-64 and of course i ve set the correct path. Although it seems that eveything is ok, when i try to view an image larger than 2mb or the resolution is higher than the default so it needs to resize a get a blue icon as a result. I have to mention that before the upgrade it was working. Now i can not even revert to ImageMagick 6 as i get the same blue icon. Help please. Thanks in advance