0
Answered

Cannot update "2019.05.21" to "2019.06.01"

pabloluih 1 year ago updated by Vlad R 1 year ago 9

I get this log when updating, and nothing else happens after the last line updating database structure...:

What could I do? It is a fresh installation.

Developer info: de:1 met:300 ml:256M
-------------------------------------
Cleaning after previous update...Done
Extracting update...Done
Running update:
-------------------------------------
Checking files permissions...all good.
Backing up "js/fileman/actions.js" ......Ok.
Backing up "js/fileman/download_cart.js" ......Ok.
Backing up "js/fileman/toolbars_and_menus.js" ......Ok.
Backing up "js/fileman/weblink.js" ......Ok.
Backing up "js/cpanel/forms/settings_branding.js" ......Ok.

[...][NO ERRORS BETWEEN LINES]

Updating "customizables/plugins/admin_indexer_test/index.html" ......Ok.
Updating "customizables/plugins/00_open_in_new_tab/index.html" ......Ok.
Updating "images/fico/blank/3d.png" ......Ok.
Updating "images/fico/blue/3d.png" ......Ok.
Updating "images/fico/dark/3d.png" ......Ok.
Updating "images/fico/green/3d.png" ......Ok.
Updating "images/fico/red/3d.png" ......Ok.
Updating folder "customizables/plugins/3d_viewer/" ......Ok.
Updating database structure...

Thanks in advance! And thanks for your effort for making this possible.

I'm getting the same result: nothing happens after "Updating database structure..." even after waiting 15 minutes. When I click "restart", FileRun thinks nothing has happened and asks me if I want to re-download the upgrade. If I refresh the web page, FileRun thinks nothing has happened and alerts me that there is an update.

Under review

Can you please check the file "system/data/temp/mysql_error.log" for any entries?

I don't have a "mysql_error.log" there. Here's my directory:

$ ls -al
total 2268
drwxrwxr-x 14 user group    4096 Jul 1 14:25 .
drwxrwxr-x 5 user group 4096 Jul 1 14:25 ..
drwxr-xr-x 7 user group 95 Jul 1 13:04 _backup_2019.06.01_1562011539
drwxr-xr-x 8 user group 108 Jul 1 13:05 _backup_2019.06.01_1562011549
drwxr-xr-x 8 user group 108 Jul 1 13:05 _backup_2019.06.01_1562011569
drwxr-xr-x 8 user group 108 Jul 1 13:06 _backup_2019.06.01_1562011632
drwxr-xr-x 8 user group 108 Jul 1 13:07 _backup_2019.06.01_1562011695
drwxr-xr-x 8 user group 108 Jul 1 13:08 _backup_2019.06.01_1562011880
drwxr-xr-x 8 user group 108 Jul 1 13:11 _backup_2019.06.01_1562012147
drwxr-xr-x 8 user group 108 Jul 1 13:15 _backup_2019.06.01_1562015649
drwxr-xr-x 8 user group 108 Jul 1 14:14 _backup_2019.06.01_1562016327
drwxr-xr-x 3 user group 47 Jul 1 14:25 _unzipped_update
-rw-r--r-- 1 user group 2295349 Jul 1 14:25 _update.zip
drwxr-xr-x 8 user group 108 Jul 1 14:25 backup_2019.06.01
-rw-r--r-- 1 user group 1361 Jul 1 14:23 cache.metadata.filetypes.tmp.php
-rw-r--r-- 1 user group 5086 Jul 1 14:11 cache.settings.tmp.php
-rw-rw-r-- 1 user group 0 May 31 00:47 index.html
drwxrwxr-x 2 user group 4096 Jul 1 05:48 smarty

There is no "mysql_error.log" inside my TEMP filerun structure, but I deleted my "mysql_error.log" from mysql of xampp to have a fresh log. And there is nothing registered after I run the update.

2019-07-02 00:10:09 138 InnoDB: Warning: Using innodb_additional_mem_pool_size is DEPRECATED. This option may be removed in future releases, together with the option innodb_use_sys_malloc and with the InnoDB's internal memory allocator.
2019-07-02  0:10:09 312 [Note] InnoDB: innodb_empty_free_list_algorithm has been changed to legacy because of small buffer pool size. In order to use backoff, increase buffer pool at least up to 20MB.

2019-07-02  0:10:09 312 [Note] InnoDB: Using mutexes to ref count buffer pool pages
2019-07-02  0:10:09 312 [Note] InnoDB: The InnoDB memory heap is disabled
2019-07-02  0:10:09 312 [Note] InnoDB: Mutexes and rw_locks use Windows interlocked functions
2019-07-02  0:10:09 312 [Note] InnoDB: _mm_lfence() and _mm_sfence() are used for memory barrier
2019-07-02  0:10:09 312 [Note] InnoDB: Compressed tables use zlib 1.2.11
2019-07-02  0:10:09 312 [Note] InnoDB: Using generic crc32 instructions
2019-07-02  0:10:09 312 [Note] InnoDB: Initializing buffer pool, size = 16.0M
2019-07-02  0:10:09 312 [Note] InnoDB: Completed initialization of buffer pool
2019-07-02  0:10:09 312 [Note] InnoDB: Highest supported file format is Barracuda.
2019-07-02  0:10:10 312 [Note] InnoDB: 128 rollback segment(s) are active.
2019-07-02  0:10:10 312 [Note] InnoDB: Waiting for purge to start
2019-07-02  0:10:10 312 [Note] InnoDB:  Percona XtraDB (http://www.percona.com) 5.6.42-84.2 started; log sequence number 4337526
2019-07-02  0:10:10 5712 [Note] InnoDB: Dumping buffer pool(s) not yet started
2019-07-02  0:10:10 312 [Note] Plugin 'FEEDBACK' is disabled.
2019-07-02  0:10:10 312 [Note] Server socket created on IP: '::'.
2019-07-02  0:10:10 312 [Note] C:\xampp\mysql\bin\mysqld.exe: ready for connections.
Version: '10.1.38-MariaDB'  socket: ''  port: 3306  mariadb.org binary distribution

Thanks in advance.

+1

Other the replacing the files, the update only runs two more MySQL queries:

INSERT INTO `df_file_handlers` (`id`, `uid`, `type`, `ext`, `handler`) VALUES (NULL, NULL, '3d', '', '3d_viewer');

and

UPDATE `df_settings` SET `val` = '2019.06.01' WHERE `var` = 'currentVersion';

and cleans the cache: deletes the file "system/data/temp/cache.settings.tmp.php"

So, technically if you manually do the above things, the update is done.

But it's strange that it fails for you guys. Can you please let me know the PHP and MySQL versions?

I'm using php .3 and mysql 5.7.25-log. 

Manually running those 2 mysql commands and deleting the cache file, worked for me - FileRun now thinks it's version 2019.06.01. 

Thanks.

Same here, with those commands and deleting the cache file is working now! Thanks.

My setup is: PHP 7.3.4 + MariaDB 10.1.38.

+1

Same error. I get this error_log:

[02-Jul-2019 13:28:23 Asia/Krasnoyarsk] PHP Fatal error:  Uncaught Error: Call to undefined function FileRun\Utils\xdebug_get_function_stack() in /var/www/clouddata/system/classes/vendor/FileRun/Utils/Strings.php:32
Stack trace:
#0 /var/www/clouddata/system/data/temp/_unzipped_update/update.php(244): FileRun\Utils\DB->query('INSERT INTO `df...')
#1 /var/www/clouddata/system/modules/software_update/sections/cpanel/php/install.php(75): unknown()
#2 /var/www/clouddata/index.php(186): unknown()
#3 {main}
  thrown in /var/www/clouddata/system/classes/vendor/FileRun/Utils/Strings.php on line 32
+1
Answered

Thank you for that information, it helped fixed the problem. The update should install now without problems.