0
Answered

Synology: access to existing /photo not allowed (permission problem?)

jcomva 5 months ago updated by Vlad R 5 months ago 13

Hi!

Just finished the FileRun install on my Synology thanks to the very detailed how to.

Now FileRun is running and I want to access the pictures I have in the default /photo folder. In the step 7 of the tutorial, "/photo" is added, but I had to insert "volume1/photo" for this to work. Nothing about allowing any user to access that folder.

I can see the subfolders of /photo inside FileRun… but not the images.

Indexing folder says “Getting directory listing....Failed!”, and if I try to upload a picture: “Failed to upload file. Server error. Please try again later.”

So I assumed I had to add the http user in DSM to read/write /photo, but that didn't change anything.

Any clue here? 🙏

Thanks! Have a great day,

Answer

Answer
Answered

Ok got it. Problem is: https://www.synology.com/en-uk/knowledgebase/DSM/help/DSM/AdminCenter/file_share_privilege >The below settings cannot be used with the following shared folders: photo, satashare, sdshare, surveillance, usbshare.
It works with any other shared folder ! With open_basedir left unticked.

Under review

Please check the PHP configuration, perhaps "open_basedir" is enabled and limited to only certain paths.

It's not: if I do enable it what should I put there?

Was it needed to allow read/write http on /photo? Is there something else I can try?

Other php config about dirs:

Tick the option "Customize PHP open_basedir" and add the path you want to manage with FileRun in there. Make sure you use the same path separator character as the other values that are already set (:).

So there where nothing in the filed, I'va added "/volume1/photo" and now I have this error in FileRun : The server HTTP response code is 405, and cannot see any folder anymore

Then leave it enabled, with an empty value.

You need to review the permissions of the folder, to allow WebStation access to it. There isn't anything else required for this to work.

So, tried to:

add ":/var/services/photo:/volume1/photo/" at the end of open_basedir

add read/write permission to every group for the photo shared folder

set ":/var/services/photo" or "/volume1/photo/" in FileRun fot superuser and the other user I created

Nothing changes:

I still see the folders in /photo/ but not their subfolders, and I cannot upload, create dir or index files :/

Make sure you apply the permissions recursively (on all subfolders and files).

Ok I finally succeded it by doing "sudo chown http:http my-test-folder", and I can see what's in that folder. What I don't get is that http is already allowed to read/write on the whole shared folder…

Answer
Answered

Ok got it. Problem is: https://www.synology.com/en-uk/knowledgebase/DSM/help/DSM/AdminCenter/file_share_privilege >The below settings cannot be used with the following shared folders: photo, satashare, sdshare, surveillance, usbshare.
It works with any other shared folder ! With open_basedir left unticked.

While I have you: there's a @eaDir folder in every single folder, but they are hidden. Still, FileRun displays them – any way to hide hidden folders in File Run?

Thanks again!

This should do it:

$config['app']['hidden_folder_names'][] = "@eaDir";

For more info about creating a config file, please see this page: http://docs.filerun.com/advanced_configuration

Oh wow that's brilliant! Imma have a closer look at this page thanks!

If I mayuse you precious help a little bit more: I'mgonna want to acces FileRun both localy and remotely. So far I've set everything up with "http://my-nas-dns-name.local/filerun/", but if I access it remotely, it says "This software application is registered to a different server hostname."

I've read that I can just delete /system/data/filerun.dat, but will it allow me to use both acces?

Thanks again a **lot**

+1

Yes, unfortunately you have to unregister the installation (by deleting the mentioned file) if you don't wish it to be tied to a particular hostname.