0

Class 'FileRun\Thumbs\Resizers\ImageMagick' not found

Pawel G 2 weeks ago updated by Vlad R 2 weeks ago 6

Hello,

i've problem with ImageMagick plugin. Photos that are equal or larger than 2mb are not showing in filerun (just blue photo icon is displaying). "Admin thumbnail troubleshooter" plugin shows me errer with imagemagick that says: "Class 'FileRun\Thumbs\Resizers\ImageMagick' not found in..." with photos that are not showing. What can i do with it?

It's local filerun installation on Windows and path to imagemagick plugin in Filerun options is correct.

Best regards,

Paul

+1

I would guess that your FileRun installation is missing files.

Follow your advice i reinstalled FIlerun with Option 1 in guide and everything is working now. Before i was installing Filerun with Option 2 "manual" method and it was not working. I thought that on Windows folder permissions aren't that important as in Linux :-|

Thank you!

i have the same issue on my Mac OS Server installation. I tried to disable or tweak the size of images before needing the help of ImageMagick, but nothing works.
ImageMagick is configured, and detected in the admin pannel.

And I can't make the troubleshooting plugin work. It's not showing up in openwith

Ok, I moved the folder somewhere else, and now they are generating... Too much inside a subfolder ?

It's not related to rights, as it can generate thumbnails on up folders. Moreover, the pictures and folders were added through Filerun.

Ok, I solved the problem. The thumbnails are generated on a different drive to improve performance. When I move the folders containing the pictures (via SMB directly on the server I think), Filerun didn't actualise the thumbnails on the other drive and was trying to open Something which didn't exist anymore. I had to remove everything to make it work again.

I suppose then that I found a bug...

Can you please check your PHP error log for the entire entry? It would help me fix this bug, as I currently can't reproduce it.